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Techniczne wskazéwki bezpieczenstwa

Podrecznik ten zawiera wskazdwki, ktérych powiniene$ przestrzegaé dla wiasnego
bezpieczenistwa oraz w celu unikniecia uszkodzenia sprzetu. Wskazdwki te oznaczono
specjalnym tréjkatem ostrzegawczym i w zaleznosci od stopnia zagrozenia nastepujaco
opisano:

Niebezpieczenstwo
Oznacza zagrozenie $miercig, powaznym uszkodzeniem ciata lub duzymi stratami, jesli nie
bedzie przestrzegaé sie odpowiednich zasad bezpieczenstwa.

Ostrzezenie
Oznacza mozliwosé wystapienia zagrozenia $miercia, powaznym uszkodzeniem ciata lub
duzymi stratami, jesli nie bedzie przestrzegac sie odpowiednich zasad bezpieczenstwa.

Uwaga
Oznacza mozliwos¢ wystapienia lekkiego uszkodzenia ciata lub strat, jesli nie bedzie
przestrzegac sie odpowiednich zasad bezpieczenstwa.

Wskazéwka
To wazna informacja o produkcie, jego uzytkowaniu lub wskazanie szczegdlnie waznej czesci
dokumentacii.

Wykwalifikowany personel

Instalacja i uzytkowanie sprzetu moze przeprowadza¢ tylko wykwalifikowany personel. W
rozumieniu tego podrecznika wykwalifikowany personel to osoby uprawnione do podtaczania,
uziemiania i oznaczania urzadzen, systemdéw i obiegéw pradu zgodnie ze standardami
bezpieczenstwa

Uzytkowanie zgodnie z przeznaczeniem
Nalezy przestrzega¢ co nastepuje:

Ostrzezenie

Urzadzenie moze byé uzywane tylko w uktadach przewidzianych w katalogu i w opisie
technicznym, tylko w potaczeniu z urzadzeniami zalecanymi lub dopuszczonymi przez firme
Siemens obcymi urzadzeniami i komponentami.

Prawidtowa i bezpieczna praca urzadzenia mozliwa jest tylko przy zatozeniu, ze nastapit
wiasciwy transport, wiasciwe magazynowanie, montaz i prawidiowe uzytkowanie i
konserwacja urzadzenia.

Znaki towarowe

SIMATIC®, SIMATIC HMI® i SIMATIC NET® sa zarejestrowanymi znakami towarowymi firmy
Siemens. Pozostate oznaczenia w tym tekscie moga by¢ znakami towarowymi, a ich uzywanie
przez osoby trzecie dla ich wtasnych celéw moze narusza¢ prawa wtascicieli.



Witamy w STEP 7...

...podstawowym pakiecie programowym SIMATIC stuzacym do tworzenia
programéw dla sterownikéw SIMATIC S7-300/400,C7/WinAc w LAD, FDB lub
STL.

Informacje zawarte w tej dokumentaciji

Podrecznik ten pozwala Panstwu zapozna¢ sie z podstawami jezyka
programowania STEP 7. Dodatkowo zostaty przedstawione najwazniejsze
operacje wykonywane na ekranach edytora poparte przyktadowymi
éwiczeniami. Dokumentacja podzielona jest tak, by mozliwe byto rozpoczecie
¢wiczen w dowolnym rozdziale.

W kazdym rozdziale znajduje sie cze$¢ opisowa i operacyjna.

Pomocne Panstwu bedg umiejetnosci pracy z myszka, ikonami, przewijalnym
menu itp. Dodatkowym atutem bedzie wiedza z zakresu sterownikéw
programowalnych.

Na kursach szkoleniowych mozecie Parnstwo pogtebi¢ wiedze z zakresu STEP
7, oraz projektowania i tworzenia systeméw automatyki z wykorzystaniem
sterownikéw SIMATIC S7.

Podstawowe wymagania pracy z dokumentacja

W celu przeprowadzenia praktycznych ¢wiczen STEP 7 z tej dokumentaciji,
konieczne jest:
e Programator PG lub komputer PC
e Pakiet programu STEP 7 i dyskietka autoryzacyjna
e Sterownik SIMATIC S7
(rozdziat 7 ,tadownie i testowanie programu”)

Dodatkowe dokumentacje do STEP 7

e STEP 7 Basic Information
e STEP 7 Reference Information

Na dysku CD programu znajduje sie elektroniczny podrecznik, ktory takze
mozna zamoéwi¢ w kazdym biurze handlowym firmy Siemens. Wszelkie
informacje z tego podrecznika sg dostepne w STEP 7 i w ,pomocy”.

Zyczymy Panstwu dobrej zabawy i powodzenia!
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1 Wprowadzenie STEP 7

1.1 Czego bedziecie si¢ Panstwo uczyé¢

Za pomoca praktycznych éwiczen pokazemy, jak proste jest programowanie w
LAD (Ladder Logic), FBD (Function Block Diagram) lub STL (Statement List)
za pomocg STEP 7.

Zawarte w poszczeg6lnych rozdziatach szczegétowe wskazowki pokazujg krok
po kroku szerokie mozliwosci zastosowania STEP 7.

Tworzenie programu z wykorzystaniem instrukcji binarnych

W rozdziatach 2 do 7 stworzymy program wykorzystujac instrukcje binarne. Za
pomoca instrukcji binarnych bedziemy odpytac¢ wejscia i wyjscia sterownika.

Przyktady programowania w tej dokumentacji bazujg m.in. na trzech
podstawowych instrukcjach binarnych.

Pierwsza funkcja binarna, ktérg bedziemy pdzniej programowac, to funkcja
AND (iloczyn logiczny). Funkcje AND mozna zobrazowa¢ w obwodzie
elektrycznym za pomoca dwdch stykow.

Styk 1 Styk 2 Przy zwartym

styku 1 i 2 zapala sie

i
j E

Druga funkcja binarna to OR (suma logiczna), ktéra takze moze zostaé
przedstawiona w obwodzie elektrycznym.

Styk 3

/g Przy zwarciu styku 3

! | lub 4 zapala sie lampka
T4
- Styk 4




Trzecia funkcja binarna to funkcja zapamietywania. Funkcja SR reaguje w
obwodzie elektrycznym na okreslone stany napiec i przekazuje je odpowiednio

dalej.

Styk S é

Komérka pamigci

Yot
Styk R

Po wcisnieciu przycisku S
lampka pali si¢ do
momentu wcisniecia
przycisku R



1.2 Wspoétpraca oprogramowania i sprzetu

Za pomocg programu STEP 7 stworzymy w ramach jednego projektu wiasny
program. Sterownik S7 sktada sie z zasilacza, CPU oraz modutéw wejscia / wyjScia
(moduty 1/0).

Sterownik swobodnie programowalny (PLC) wykonujac program nadzoruje i steruje
praca maszyny. W programie poszczeg6lne wejscia i wyj$cia modutéw wywotywane
sg przy uzyciu adreséw.

Kabel do Programator/Komputer PC
programowania

Przestanie stworzonego
programu

Sterowana
maszyna

Modut wyjs¢

Zasilacz Modut wejsé




1.3 Podstawowe operacje w STEP 7

Przed rozpoczeciem projektowania, powinni Panstwo wiedzie€, iz projekty w
STEP 7 moga by¢ tworzone w réznorodnej kolejnosci postepowania.

Stworzy¢ rozwigzanie systemu sterowania

Zatozy¢ projekt (Roz.2)

Mozliwos$é 1 Mozliwosé 2

Konfiguracja sprzetu
(Roz.6)

Stworzenie programu
(Roz.3 do 5)

Stworzenie programu
(Roz.3 do 5)

I I

Przenies¢ program do CPU i przetestowaé (Roz.7)

Konfiguracja sprzetu
(Roz.6)

Przy tworzeniu skomplikowanych programoéw z duzg iloscig wejs¢é i wyjsé
polecamy stworzenie najpierw konfiguracji. Zaletg tego sposobu jest
wskazywanie w edytorze konfiguracji mozliwych do wykorzystania adreséw
wejsc/wyjse.

W drugim sposobie nalezy ustali€¢ sobie adresy sterownika w zaleznosci od
posiadanego sprzetu bez wykorzystania w tym celu konfiguracji w STEP 7.

Tworzgc konfiguracje sprzetowg ustalone zostajg nie tylko adresy
poszczego6linych modutéw, ale mozemy takze ustali¢ parametry i zachowanie sie
poszczegolnych elementéw sprzetu. Np. dla systemu sieciowego w ktérym
mamy do czynienia z kilkoma sterownikami, mozemy ustali¢ adresy w sieci MPI
dla poszczegolnych CPU.

Poniewaz w tej dokumentacji nie bedziemy uzywali
duzej ilosci wejsc i wyjs€, pominigta zostanie
konfiguracja sterownika i przejdziemy od razu do
programowania.




1.4 Instalacja STEP 7

Niezaleznie od tego, czy rozpoczynamy projektowanie od programowania,
czy tez konfiguracji sprzetu, nieodzownym jest zainstalowanie STEP7.
W przypadku uzycia programatora STEP7 jest juz w nim zainstalowany.

SIMATIC

Manager

Przed instalacjg STEP7 na PG/PC
bez zainstalowanej wersji nalezy
zapoznac sie ze wskazéwkami
dotyczacymi sprzetu i
oprogramowania. Znajdujg sie one na
CD STEP7 w zbiorze Readme.wri.

W celu zainstalowania STEP7 nalezy
wtozy¢ CD. Program instalacyjny
uruchomi sie automatycznie. Nalezy
postepowaé wg wskazdwek.

Jesli program instalacyjny sie nie
uruchomi automatycznie, nalezy go
znalez¢ na CD pod

<dysk>:/STEP 7/Disk1/setup.exe

Po zakonczeniu instalaciji i
restartowaniu komputera na
Windows Desktop pojawi sie ikonka
SIMATIC Manager.

uruchomienie edytora STEP7.

Podwdjne klikniecie na powstatg ikonke SIMATIC Manager powoduje

Dalsze informacje dotyczace instalacji
zawarte sg w zbiorze Readme.wri
znajdujgcym sie na CD STEP7.
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2 SIMATIC Manager

2.1

Uruchomienie SIMATIC Manager i zaktadanie projektu

Po uruchomieniu STEP7, gtéwnym aktywnym oknem jest SIMATIC Manager.
Jednocze$nie uruchamiany moze byé Wizard STEP7, ktéry pomaga w
zatozeniu nowego projektu. Projekt tworzony jest z zachowaniem
odpowiedniej struktury.

W ramach projektu przechowywane
sg w hierarchicznej strukturze

:rhed)

e — W ramach stacji SIMATIC
|C 300 Statio

| umieszczane sg dane

konfiguracyjne i parametry

=2] 57 F’rgram
(@] Sources
(g3 Blocks

Program S7 zawiera bloki
programu sterowania
automatyzowanej maszyny.

Dwukrotne klikniecie na ikonke SIMATIC
Manager uaktywnia sie Wizard Step7.

Za pomocg przycisku Preview podejrze¢

' Intoduction 1 mozna strukture zaktadanego projektu.
¥ STEP 7 Wizard: "New Project®

s e R By przej$¢ na nastepne okienko

— dialogowe nalezy wcisng¢ Next

.~ 1 Click one of the following options:
11 "Next"to craate your project step-by-step

" "Make" to ereate your project according to the preview

1 Displap wizsrd on starting Hhe SIMATIT Mansges < MI

[2) §7_Fra2 Block Name 5 mbolic Hame

= {l] SIMATIC 300 Station F 0BT Cycle Exeeution
=l cPUT2 M)
- 34] 57 Program(1)

< Hewt> ) Make Cancel Help
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STEP 7 Wizard: "New Project”

Wykonujac projekt éwiczeniowy
wybierz CPU 314. Przyktad jest tak

BEST 312-534002-04B0 . - . -

6EST 312-14003-0480 Wykonany, Ze mozna ]ednak WybraC

BEST 314-1AE04-0480 . . .

BESTIMMEIIEN o aktualnie posiadany sterownik.

BEST 315-24F03-04B0

Wstepnie ustawiany jest adres MPI o
numerze 2.

Przejscie do nastgpnego okna
el Execuion nastepuje po Kliknigciu przycisku Next.

57 Pragramil)
3 Blacks

STEP 7 Wizard: "New Project”
T — Wybierz blok OB1 jesli nie jest jeszcze
Cycle Execution Zazn aczo n y_

Tirne of Day Intermupt 0
Time of Day Intermupt 1
Time of Day Inberrupt 2

Tine of Day e 3 Wybierz sposéb prezentacji programu:
(LAD) Ladder Logic — schemat
drabinkowy, (STL) Statement List —
lista instrukcji, (FBD) Function Block
Diagram — logiczne bloki funkcyjne.

Cycls Exsoution

=] cPuma()

£ 57 Frogon(l) Potwierdz ustawienia za pomoca,

e —— klawisza Next.
| Ceed | hep |

12



STEP 7 Wizard: "Mew Project”

7} What do you want to call your Eroie:t? 4i4)
N
el T T [Getting EIarted)

Kliknij dwukrotnie na nazwe
projektu (pole ,Project name”) i

e = wproyvadz nowg nazwe np.
e = ~Qaetting Started”.
Check your new pioject in the preview
SE[\;EL;‘L:V'\lakE” to ereate the project with the displayed ) . )
Kliknij na przycisk Make w celu
wygenerowania projektu wedtug
Provicc dokonanych ustawien.
=) Getting Started Block Name [ Spmbolic Name. |
=+l SIMATIC 300 Station LR Cyole Execution
’J = J EPUFTa)
= 8] 57 Program{1]
+.=] Blacks

—
«Back | e >(| Make )| Cancel Help
NG

Po kliknieciu na przycisk Make w oknie SIMATIC Manager ukaze sie projekt z
nowg nazwg (np. ,Getting Started”). Na kolejnych stronach przedstawione
zostanie znaczenie poszczegolnych elementow tworzonej struktury projektu, oraz
podamy efektywne metody ich wykorzystywania.

Wizard STEP7 bedzie uruchamiany kazdorazowo przy uruchomieniu programu.
Te wtasnos¢ mozna dezaktywowaé w pierwszym ukazujacym sie okienku. Jesli
chcemy tworzy€ projekty bez wykorzystania Wizard, nalezy tworzy¢ projekt
ustawiajgc kazdy z parametréw projektu niezaleznie.

Dalsze informacje znajdujg sie w Help

> Contents "Setting Up and Editing the
Project”.

13



2.2 Struktura projektu w SIMATIC Manager oraz wywotanie pomocy
do STEP7

Z chwilg zakonczenia tworzenia projektu przy pomocy Wizard w SIMATIC
Manager otwarte zostaje okno projektu (np. ,Getting Started”). Z tego poziomu
mozliwe jest wywotywanie wszystkich funkcji i okien edytora STEP7.

Otwarcie, organizacja,

wydruk projektu
Tworzenie blokéw i elementow Ustawienie
programu przyporzadkowania i formatu
okna, wyboér postaci jezyka,

ustawienia danych
Przestanie programu i procesowych
obserwacja sprzetu

Pomoc do STEP7

&j SIMATIC Manager - Gg tling Started

D|b|ga| =] 3 (e[ d _||—_||:: & [evorie %] @ x|

Gietting Started
=@ SIMATIC 300 Station
=-[@ crust4m
57 Program{1]
Jource Files

Okno z prawej strony ukazuje
obiekty i inne foldery znajdujace
sie w folderze zaznaczonym w #
lewym oknie

Press F1 far help.

L1

W lewej czesci okna pokazana
jest struktura projektu

14



Wywotywanie pomocy do STEP 7
F1

e r-ﬁd. r.E.‘ r.‘?"

Owerview of STEP 7 ‘|
Whatis STEP 7

r

=M
I

FIFPUIIIII 9999999999599 i '

e .
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Mozliwosé nr 1:

Zaznacz dowolne polecenie Menu i
nacisnij przycisk F1. Otrzymasz
fachowg pomoc dotyczaca
zaznaczonego polecenia Menu.

Mozliwosé nr 2:
Poprzez Menu wchodzisz do pomocy
do STEP 7.

W lewym polu okna pokazuje sie spis
tresci zawierajgcy rozne tematy
pomocy, a w prawym polu wybrany
temat.

Poszukiwany temat znajduje sie
przyciskajac + w polu Contents. W
prawym polu okna pojawia sie
jednoczesnie zawartos¢ wybranego
tematu.

Za pomoca Index i Find mozna
podawac szukane okreslenia i w ten
sposo6b odnajdywac zgdane tematy
pomocy.

Mozliwos$é nr 3:

Klikna¢ na ikone "Start page” w STEP
7 Online Help, ktéra umozliwia
wyswietlenie informacji pomocniczych
wedtug nastepujacych rozdziatéw:

- Getting Started with STEP 7;

- Configuring & Programming;

- Testing & Debugging;

- SIMATIC on the Internet

Mozliwo$é nr 4:
Kliknij na ikone pomocy. Kolejne

klikniecie na okreslony obiekt
aktywuje pomoc.



Poruszanie sie w strukturze projektu.

Zatozony wiasnie projekt
File Edit Insett PLC “iew Options Window Help pokazywany jeSt z Wybl’anq
D] 87w % ||| il [o [ stacjg S7 i CPU
= Kliknij na + lub — w celu otwarcia
Getting Started ieci A

L iF Iu_b gamknlema poszczegoinych
B cruzia) 0B plikow.
=) {2 57 Progian W prawym polu ekranu

Getting Started - C:ASiemens\Step?\S 7proj\Gell

(@] Sources ; , .

o wskazujac poszczegdlne obiekty
mozna pozniej wywotac kolejne
funkcje.

Kliknij na plik S7-Program (1).
Zawiera on wszystkie konieczne
czesci sktadowe programu.

Za pomocg symboli nadaje sie
adresom symboliczne nazwy
(patrz rozdz. 3).

Grupa Source File zawiera
programy zrédtowe. Programy
zrodtowe nie sg omawiane w tej
dokumentaciji.

Kliknij na plik Blocks. Zawiera on
juz zatozony OB1. Tam tez
pbzniej znajdziemy kolejne bloki.

Wykorzystujgc bloki
wprowadzany jest program
sterownika w postaci LAD, STL
lub FBD.

Kliknij na SIMATIC 300 Station.
Tutaj znajdujg sie dane
projektowe konfiguracji

consie sprzetowe).

& Getting Staried - CASIEMENS SIS0\ Gottin_1

Hardwaney

Ikona Hardware umozliwia
wejscie w ustawienia konfiguraciji
sprzetowej (patrz rozdziat 6).

Pakiety opcjonalne takie jak np. PLS-SIM (symulacja pracy sterownika), czy tez
S7-GRAPH (graficzne programowanie), sg po zainstalowaniu zintegrowane w
STEP?7. Dlatego tez np. bloki funkcyjne stworzone w S7-GRAPH mozna
wywotywaé bezposrednio w SIMATIC Manager.

Dalsze informacje znajduja sie w Help>Contents w

temacie ,Working Out the Automation Concept” oraz
"Basics of Designing the Program Structure”.

Wiecej informacji na temat pakietéw opcjonalnych
znajdziecie Panstwo w katalogu ST70 prezentujacym
rodzine SIMATIC.

16



3 Programowanie symboliczne

3.1 Adresowanie absolutne

Kazde wejscie i wyjscie posiada adres absolutny wynikajacy z konfiguracji
sterownika. Adres ten jest okre$lany bezposrednio, tzn. absolutnie.

Adresy absolutne mozemy zastapi¢ dowolnymi nazwami symbolicznymi.

Modut wejs¢

Modut wyjs¢

cyfrowych cyfrowych
Bajt 0 Bajt 4
Bity o do 7 Bityodo 7

Modut wejs¢

Modut wyjs¢

cyfroyvych cyfrowych
' Bajt 1 Bajt 5
Bity o do 7 Bity 0 do 7

Adres absolutny: | 15
\
Wejscie Bajt 1 Bit 5

17



3.2 Programowanie symboliczne

W tabeli symbolicznej okresla sie nazwy symboliczne przypisujac je adresom
absolutnym elementéw, ktére majg byé uzywane w programie; np. Wejscie
10.1 oraz symbol ,Przycisk 17 . Nazwy obowigzuja w catym programie i sg
okreslone jako zmienne globalne.

Praca w edytorze symboli

Nalezy w projekcie zaznaczy¢
poziom S7-program(1) i klikajac
dwukrotnie ikonke Symbols
otworzyc tabele symboli.

Poczatkowo tabela symboli
zawiera jedynie wstepnie

zdefiniowang nazwe bloku OB1.

Skatus

L (@

e e— Kliknij Cycle Execution i zamien

B 1 (0B i we wiasng nazwe programu np.

~Main Program’.

Status

Symbaol

nddress | Data type Whprowadz w drugiej linii nazwe

Main Program

o8 1 (0B 1 symboliczng np. Green Lighti

Green Light

e 40 [soo adres Q4.0. Typ danej zostanie

dobrany automatycznie.

Comment Klikajac na kolumne Comment

-

mozemy wprowadzi¢ komentarze
do symboli. Wprowadzanie
nowego wiersza koficzymy
wcisnieciem przycisku ENTER.

Status

Symbaol

Main Program

Address Data type z TP
5 1 o5 1 Wprowadz w trzeciej linii nazwe

Green Light

@ 40 |moal »Red light” oraz adres Q4.1 i

Rad | inkt

oo e wcisnij ENTER w celu zakoriczenia
operaciji.

W ten sposéb mozemy przypisa¢ symbole do
wszystkich uzywanych w programie elementéw.
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=

Zabezpiecz wprowadzone symbole za
pomocg ikonki Save i zamknij okno.

Istnieje mozliwos¢ kopiowania tabeli symbolicznych (np. z przygotowanego

projektu).

& Symbol E ditor - S7-Program(1]{5pmbols)-ZEnl_01_STEF?__STL_1-9\SIMATIC 200[1\C.... [9[=] B3

Symbol Tebe  Edb |nset Wiew Oplions  Window Hels

@[S % B o e [ASmb -1 | w2

=) 57-Program(1){Symbols)-ZEnl_01_STEP7__STL_1-S\SIMATIC 30001)\CPL314(1) [_ [0 %]
Stebus | Syrbel 2 Alidiemss Blaka Lype Coirert

1 @ 42 B3Ol Reetenfive ol |

2 Automatic_On I D& BoOL For the memary functon (evrkch on)

3 LE_Actusl_Speed My W1 Actual speec! for clesel engine . .

4 OF _Faiurs ETENEET Dissel ergine felire Obok przedstawiona jest
<) CC_Fan_on @ 40 DooL Command for swilching on diesel eaine fa i

3 DE_Falow_0n 11 TMER [Fellaw-on tire for desel engine fan tabela symbollczna dla
Fl CE_on o 54 Bl Command Tor swaching on diesel engne prog ramu "G e‘ttl ng
[ DF_Fresel_Speed R |G 55 |BoOI Displey "D Bngine presel speed reache ”

] Diezel e 2 FB 1 (Dala for dizsel enuine Started ° L, .

10 Engre FE 1 =N Engine contol Ogélnie  méwiac dla
11 Fan FCo1 FC 1 Far cotrol

12 ciren_Lighl G 40 |Ecol Fresll nf AND oy danego programu
13 Fey 1 1 04 BZaL [Farthe AND guery tworzona Jest tylko Jedna
14 Fey_2 [H BoOL For the AND guary :

15 Wey_4 [BE] R For the CF query tabela SymbollCZna bez
16 hey_4 |04 BoOL For th OF [isry i

17 Main_Frogram [T | "= This biock cortaine e user progrem WZngdu n_a quyk
18 Marvel_Cn | DE BOOL Far the memary funcan (evkch oif) programowania.

19 FE_Actual_Speed [T HT Actusl speect ior pefrol engine . . .
Zn FE_Faiure (R Bool Petiol s falurs W tabeli symbollczngj
| FE_Fan_on @ 62 |Bool Cormand far switching en petiel enaine o dOZWOlONE g wszystk|e
fy I'E_Folaw _Gn 1 1 T MEH Fallowy-an time for patral ongine tan . .

3 FE_n (¥ ] a0 BoOL Command for swtching on petrol @ngne Znakl Specjalne (np-
24 FE_Presel_Speed Re.. |G &1 B2l Display "Pel ol e cine presst speed reches pOlSkie fonty)

=5 Fetral [ FB 1 Data for pelr ol ergine

26 Fed_ Lokt Q 41 BoOL Rezult of O cusm

& = _Lets (K1 RS Sharsd cata ninct

i} Swich_Off_ DE I 13 B2OL | Fwitch off diesel erane

29 Swetch_off FE (K BoaL Switch off petrol ergire

= Shebeh_ton_LE [ Bl Swatch on diseal sngine

51 Swkeh_on_FE [ Bl SWALCh on peEtict engine

[EER

Format danej, ktéry w tabeli symbolicznej jest nadawany automatycznie,
obowiazuje takze pdzniej w jednostce centralnej. STEP7 umozliwia nadanie

miedzy innymi nastepujacych typow danych:

BOOL Dane tego typu sg kombinacjg binarng BOOL —1bit do
BYTE DWORD- 32 bity

WORD
DWORD

CHAR Dane tego typu zawierajg doktadnie jeden znak kodu

ASCII

INT Te typy umozliwiajg prezentacje wartosci liczbowych (np.
DINT stosowanych w obliczeniach arytmetycznych)

REAL

S5TIME Dane tego typu reprezentujg réznego rodzaju zmienne
TIME daty i czasu charakterystyczne dla STEP7(np. ustawienie

DATE czasu za

daneao Timera)

TIME OF DATE

Wiecej informacji znajdziesz w Help->Contents

w rozdziale ,Programming Blocks” oraz
,Defining Symbols”.
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4 Tworzenie programu w bloku OB1

4.1 Otwarcie edytora LAD/STL/FBD

Wybor LAD Ladder Logic (zapisu drabinkowego), STL Statement List
(listy instrukgcji), lub FBD Function Vlock Diagram (blokéw logicznych)

W STEP7 mozemy tworzy¢ programy w trzech postaciach: LAD, STL i FBD.
Praktycznie nalezy wybraé¢ (takze w tym rozdziale) ktérg postacig sie
postugujemy.

LAD (schemat drabinkowy)

”Przycisk1” ”Przycisk2” ”Zielone”

| | | | [ |

|
| | || S —

STL (lista instrukciji)

A "Przycisk 1”
A "Przycisk 2”
= "Zielone”

FBD (bloki logiczne)

"Przycisk 1”_| &
*Zielone”

"Przycisk 22 =

Blok jest otwierany w postaci, ktéra zostanie
wczesniej ustalona podczas jego tworzenia. Pdznigj
mozemy dokonywa¢ zmian ustawiajgc jedng z w.w
postaci.
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Kopiowanie tabeli symboli i otwieranie bloku OB1

Jpen Project

ser projects I Lihrariesl 5

 (3ating Started

g
=l SMATIC 2001)
=l cruzam)

Jesli to konieczne, otwdrz projekt.
W tym celu Kkliknij na przycisk
Open na listwie narzedziowej,
wybierz nazwe projektu i nacisnij
OK.

W zaleznosci od tego, jaki jezyk
zostat wybrany, otwérz jeden z
projektow:

* GS-LAD-Example

* GS-STL-Example

* GS-FBD-Example

Tutaj mozesz zobaczy¢ wszystkie
trzy postaci przyktadowego
projektu.

Znajdz w przyktadowych
projektach tabele symboliczng i
skopiuj ja metoda ,Drag and Drop”
do swojego projektu.

Potem zamknij okno
przyktadowego projektu.

.Orag and Drop” oznacza, iz zaznaczamy
interesujacy nas obiekt i przenosimy go w miejsce
docelowe trzymajac caty czas klawisz myszy. Jesli
puscimy klawisz myszy, obiekt zostaje umieszczony
we wskazanej pozyciji.

arted - C:ASIEMENSAS TP of\Gettin_1

Kliknij podwéjnie na blok OB1 w
swoim projekcie. Zostaje w ten
sposdb otwarte okno edytora
LAD/STL/FBD.

W sterowniku blok OB1 jest wykonywany cyklicznie. CPU analizuje linie po linii
wykonujac poszczegdélne rozkazy programu. Gdy CPU powraca do pierwszej
linii, zakonczony zostaje jeden cykl. Czas przetwarzania takiego kawatka
programu nazywa sie czasem obiegu petli, lub inaczej czasem cyklu.

W zaleznosci od tego, jaka postac STEP7 zostata wybrana, kontynuuj prace
czytajac rozdziat 4.2 — LAD, 4.3- STL lub 4.4- FBD.
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Okno programowania w LAD/STL/FBD

Wszystkie bloki programowe tworzone sa w oknie LAD/STL/FBD. Ponizej
widoczne jest okno w postaci LAD.

Umieszczanie

nowej sieci
Otwieranie i zamykanie katalogu L
elementéw programowych i struktury WaZU'eJSZG elgmenty schematu
wywotywania blokéw. drabinkowego i bloku
funkcyjnego

Zmiana jezyka
programowania

@LADISTLIFBD - [OB1 -- Gettihg Started\SIMATIC 300 Station\CPU3%4(1]]

i Eile %nil }nml P;C gebqg ¥Jew Pmm ¥MUW ﬁ* ) : =1 _laﬁl
o = T s ) e O N R
e S T
Al [Contents OF Envicnmentilnieriace\TEMP
Interface ][ [Name Dala Type  |Address  |Comment B
K1 New network =& TEMP '@ [0B1_EV_C.. |Byte 0.0 Bits 0-3 = 1 (Coming event), Bit..
= [OB1_EY_CLASS '@ OB1_SCAN  |Byte 10 1 (Cold restart sean 1 0f OB 1),
T (181 SCAN = 0B1_PRIO.. |Bvte 20 Priority of OB Execution
‘= OB1_PRIORITY @ 081_0 = =
Katalog o pEveR ||m oeirq  Tabela deklaracji parametréw —
elementow (w o os1_ReserveD_2 | OF1FY oraz zmiennych lokalnych bloku
tym przypadku @ 0B1_PREV.CYCLE @ OB1_PR
p = 081 MN Crole == oBi_m 1. =]
LAD) i ‘ - =
struktura Hetwork 1: Title:
wywotan = .
y[wa — Tytut i komentarz do —]
<) - . . =i
£ NES bloku lub sieci
£ Pos
(€] Comparator ‘ ‘—I
[ &g Conwverter ‘
1+/-{#4] Counter
{58 DE cal . o
# (] Jumps Linia programu (siec)
B-(z1) Integer fct
#-{z§ Flosting-point fct. =
I | LIJ
|

AR TEnor A 2nto A 3 CiossPeferences A 4Addessinfo._ A 5 Modfy A 6 Disgnostics A7, Comparison [/
Press F| to get Help. Okno z zakladkami wyswietlajace
dodatkowe informacje: informacje o
btedach, symbolika zmiennych,

monitorowanie zmiennych, poréwnanie
Informacja do wybranego elementu blokéw oraz wyswietlanie diagnostyki
procesowe;j.
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4.2 Programowanie OB1 w schemacie drabinkowym

W tym rozdziale przedstawione jest tworzenie w schemacie drabinkowym
potaczenia szeregowego, réwnolegtego i funkciji SET/RESET.

Programowanie potaczenia szeregowego w LAD

Jedli jest to konieczne, nalezy
wybraé jezyk LAD w menu View.

Clrl+1
Ctrl+2
Clrl+3

Kliknij na tytut bloku (Title:) i
OB 1 wprowadz tekst np. ,Program

gfowny wykonywany cyklicznie”.

o

I
m
= -

Cormoent :

Zaznacz miejsce do
E— | umiejscowienia pierwszego styku.

Kliknij na ikone styku na pasku
_I I_ narzedziowym.

. W ten sam sposob dodaj drugi
}—( | styk.

_{} Umies¢ cewke po prawej stronie
| linii.

Aktualnie znajduje sie kompletna
[ | — linia logiczna, lecz brakuje adreséw
nad stykami oraz cewka.

Sprawdz, czy aktywna jest firma
wyswietlania adreséw jako
reprezentacja symboliczna.

Diizplay ¥ Sumbolic Boproscrtation Chili 0

Symbal [nformation Chrl+5 hift«0)
Sumbal Selection Chil+7
v Comments Ctrl+5hiftek,
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i 7/, Kiknij 22.2 i wprowadz nazwe
symboliczng ,Przycisk_1". Zatwierdz

Enterem.
v ey —n Wprowadz dla drugiego styku nazwe
}—u % {—  Przycisk_2".

e e Fald Dla cewki wprowadz nazwe
JZielone_Swiatlo”.

I PrzYcilsk_1 Przlycisk_2 ZieloneTSwiatIo W tym momencie zostato zakonczone
L ) .. .
| UL U L L tworzenie rownania szeregowego.

gl Jesli nie ma zadnych czerwonych

symboli, zapisz blok.

Symbole bedg zaznaczane na czerwono, jesli np. nie bedg
zdefiniowane w licie symbolicznej, lub wystapit btad sktadni.

Mozna takze wprowadzi¢ bezposrednio nazwe symboliczna. Kliknij na
znak ??.? a nastepnie wybierz w menu Insert-> Symbol. Znajdz w
liscie odpowiedni symbol. Nazwa dodawana jest automatycznie.
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Programowanie potaczenia réwnolegtego w jezyku LAD

P
DTS Ticle:
[C_Dnment:

0

E
&

==
IE

L

L\
=

"Rped_Light
"Key 3" "

{ {1

"Key_4"

25

Woybierz sie¢ Network 1

Wprowadz nowa sie€.

Zaznacz aktualng siec.

Kliknij klawisz styku i cewki na listwie
narzedziowej.

Woybierz linie prostopadta do danej
sieci.
Dodaj rozgatezienie rownolegte.

Dodaj drugi styk normalnie rozwarty
do rozgatezienia.

Zamknij rozgatezienie (jesli potrzebne,
to wybierz dolng strzatke)

Kompletna linia logiczna bez
wypetnionych adreséw.

By dodac¢ adresy symboliczne, nalezy
powtdrzy¢ procedure z potaczenia
szeregowego.

Dodaj oznaczenia dla stykow

~Przycisk_3"i ,Przycisk_4”, a dla
cewki ,czerwone_swiatlo”.

Zapisz blok.



Programowanie przerzutnika SR

nwra]  Wybierz Network 2 i dodaj kolejng
F==|  siec

Zaznacz aktualng siec..

Wyszukaj w katalogu w Bit Logic
element SR.

Dodaj styki przed wejsciem S i R.

"Automatic
"Automatic _Mode"

Woprowadz nazwy symboliczne funkciji

_on”

SR

SR.

Q

El Zapisz blok.

Aby zobaczyé roznice pomiedzy adresowaniem symbolicznym i
absolutnym, nalezy wytaczyé reprezentacje symboliczng w
View>Display>Symbolic Representation.

Mozesz takze zmieni¢ szeroko$¢ styku wybierajgc w menu
Options>Customize w pozycji ,Width of adress field” w zaktadce
-,LAD/FBD”. Tutaj mozesz ustawi¢ szerokos¢ 10 do 24 znakdw.

Wiecej informaciji znajdziecie w Help>Contents w
pozycjach ,Programming Blocks”-programowanie
blokow, ,Creating Logic Blocks” - tworzenie
blokow, i ,Editing Ladder Instructions” — edycja
instrukcji w schemacie drabinkowym.
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4.3 Programowanie OB1 w liscie instrukcji (STL)

W tym rozdziale przedstawione jest tworzenie w liscie instrukcji rozkazéw
AND, OR i instrukcji S — set, R —reset.

Programowanie instrukcji AND w postaci STL

Chil+1
Clil+2
Chl+3

Jesli jest to konieczne, nalezy
wybrac posta¢ STL w menu w
pozycji View.

v [
| Sprawdz, czy jest aktywna
Displag * v Symbolic Bepresantation ChliQ reprezentacja symboliczna.
Symbol [nformation CikeShift+0)
Symbol Selection Chile?
v Comments CirbsShift+K
oB1 Kliknij na tytut bloku (Title:) i
Coment : wprowadz tekst ,Program gtéwny
wykonywany cyklicznie”.
birc twork 19K TSI - S
P Zaznacz miejsce wtozenia
pierwszej instrukcji.
A Przycisk_1” W pierwszej kolejnosci wpisz A

(AND), nastepnie spacje a potem
nazwe symboliczng ,Przycisk_1".

Zakoncz linig za pomoca przycisku

Enter. Kursor przeskakuje do
nastepne;j linii
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A »Przycisk_1” W ten sam sposob uzupetnij dalsze instrukcie.
A ~Przycisk_2”
= LZielone_swiatlo”
n Zostata stworzona kompletna funkcja AND.
Zapisz blok, jesli zaden z symboli nie jest juz

podswietlany na czerwono.

Symbole beda zaznaczane na czerwono, jesli np. nie beda
zdefiniowane w liscie symbolicznej, lub wystapi btad sktadni.

Mozna takze wprowadzi¢ bezposrednio nazwe symboliczna. Kliknij na
znak ??.? a nastepnie wybierz w menu Insert-> Symbol. Znajdz w
liscie odpowiedni symbol. Nazwa dodawana jest automatycznie.

Programowanie instrukcji OR w STL

Wybierz Network 1.

1 tJritle:

Comment:
HH Wstaw nowg siec i przejdz do obszaru
=== | wprowadzania instrukciji.

(0] ~Przycisk_3” Woprowadz O (OR), spacje, oraz nazwe
symboliczng ,Przycisk_3” (w taki sam
sposéb, jak w instrukcji AND)

0 Przycisk_3” Uzupetnij instrukcje i zapisz blok.

(0] ~Przycisk_4”

,Czerwone_swiatlo”
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Programowanie przerzutnika SR
Wybierz Network 2 i wstaw nowa sieé

Hi=
=
A »~Automatyka_ON” WprowadZz w pierwszej linii instrukcje
A z oznaczeniem symbolicznym
sJAutomatyka_ON”
A ~Automatyka_ON” Uzupetnij pozostate instrukcje. Zapisz
S SAUTO_ZAL” blok.
A ~-Reka_ON”
R LAUTO_ZAL”

Aby zobaczy¢ réznice pomiedzy adresowaniem symbolicznym i absolutnym,
nalezy wytaczyc¢ reprezentacje symboliczng w View>Display>Symbolic
Representation.

~Przycisk_1” Przyktad: Adresowanie symboliczne w STL
~Przycisk_2”
LZielone_Swiatlo”

> >

I 0.1 Przyktad: Adresowanie absolutne w STL|
| 0.2
Q 4.0

> >

Wiecej informaciji znajdziecie w Help>Contents w
pozycjach ,Programming Blocks”-programowanie
blokoéw, ,Creating Logic Blocks” - tworzenie
blokoéw, i ,Editing STLInstructions” — edycja
instrukcji w liscie instrukcji.
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4.4 Programowanie OB1 w blokach logicznych (FBD)

W tym rozdziale przedstawione jest tworzenie w blokach logicznych rozkazéw
AND, ORi instrukcji S — set, R —reset.

Programowanie funkcji AND w blokach logicznych

L&D Ctil+1

Chil+2
Ctled

Jesli jest to konieczne, nalezy
wybrac¢ postaé FBD w menu w
pozycji View.

Kliknij na tytut bloku (Title:) i
wprowadz tekst ,Program gtowny

SetiEn wykonywany cyklicznie”.
fite twork 188 SIS Zaznacz miejsce wiozenia
[Comment : InStruijI AND

7, 7—

??2. 72—

Display * « Symbolic Bepressntation Chil+Q
 Symbol Information Chrl+Shift+0

Symbol S=lection Crl+7
v Comments Chil+Ehift+K,

30

Wprowadz blok AND (&) i (=).

Adresy w stworzonej funkcji nadal
pozostajg nieokreslone.

Sprawdz, czy aktywna jest
reprezentacja symboliczna.



&
72,7
27, 7 —
&
22, ?— 2.2
&
27y 2.2
72, 7 = —
i "Green Lig
"KE? 1 — ht'r
"KE‘E’ ar —

=1

Kliknij ??.? i wprowadz nazwe
symboliczng ,Przycisk_1".
Zatwierdz klawiszem Enter.

Wprowadz nazwe symboliczng
+Przycisk_2” dla drugiego wejscia.

Wprowadz nazwe
LZielone_Swiatlo” dla instrukciji
przypisania.

W ten sposo6b uzyskujesz
kompletnie stworzong funkcije
AND.

Jesli nie ma zadnych symboli
wskazywanych na czerwono,
mozesz zapisac blok.

Symbole beda zaznaczane na czerwono, jesli np. nie beda
zdefiniowane w licie symbolicznej, lub wystgpi btad sktadni.
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Programowanie funkcji OR w blokach logicznych

HH
=

Compent @

g

PP P — 22.?
?2. 72— )
==1 "Red Light
"KEY—3 L — "
"KEY_'q L —

=]
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Wprowadz nowg sie¢

Zaznacz miejsce do wstawienia
funkcji OR.

Kliknij ikonke funkcji OR (=1) i
przepisanie (=).

Dodaj oznaczenia dla stykow
~Przycisk_3"i ,Przycisk_4”, a dla
funkcji przypisania
~czerwone_swiatlo”.

Zapisz blok.



Programowanie funkcji zapamietywania w FBD

HH2|  Wybierz Network 2 i dodaj kolejng
"_l sieé. Zaznacz aktualng siec.

Wyszukaj w katalogu w Bit Logic
element SR. Kliknij na niego
dwukrotnie.

AUTO_ZAL

Wprowadz nazwy symboliczne funkcji

i SR.

Automatyka_ON
—
Reka_ON

g I Zapisz blok.

Aby zobaczyé roznice pomiedzy adresowaniem symbolicznym i
absolutnym, nalezy wytaczyé reprezentacje symboliczng w
View>Display>Symbolic Representation.

Mozesz takze zmieni¢ szeroko$¢ styku wybierajgc w menu
Options>Customize w pozycji ,Address Field Width” w zaktadce
,LAD/FBD”. Tutaj mozesz ustawi¢ szerokos¢ 10 do 26 znakdw.

Wiecej informaciji znajdziecie w Help>Contents w
pozycjach ,Programming Blocks”-programowanie
blokow, ,Creating Logic Blocks” - tworzenie
blokow, i ,Editing FBD Statements” — edycja
instrukcji w schemacie drabinkowym.
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5.1

Tworzenie programu z wykorzystaniem blokow
funkcyjnych i blokéw danych

Dodawanie oraz otwarcie bloku funkcyjnego (FB)

Blok funkcyjny FB hierarchicznie jest przyporzgdkowany do bloku
organizacyjnego. Wszystkie parametry formalne oraz zmienne statyczne
zapamietywane sg w specjalnym dotgczonym bloku danych (DB).

W oknie edytora LAD/STL/FBD tworzymy blok funkcyjny (FB1 o nazwie
symbolicznej np. ,Engine”; patrz tabela symboliczna, rozdz.3). By to wykonac,
nalezy postugiwac sie informacjami zawartymi w rozdziale 4 (programowanie
bloku OB1).

Istnieje mozliwo$¢ skopiowania
oryginalnej tabeli symbolicznej z
projektu ,Getting Started”. Sposéb
« wykonania tej operacji jest opisany
w rozdz.4.

i
1
D L
ZDwn_D2_STEP... [
zow1_p3_STEP.. ( Jesli jest to konieczne, otwérz
o bearce. ( Projekt Getting Started”.
ZDt01_06_STEP... (

_]_]‘ _ .

tod — CASIEM I'li:i'.‘)ll:'?\(- Tpioi\Gettin_1 O Zn ajdz’ i OtWé rZ fo | der B Iocks .

Kliknij na prawej czesci okna
prawym klawiszem myszy.

1 Pojawito sie okienko menu

| zawierajgce wazniejsze operacje
zawarte w listwie menu. Wstaw
jako nowy obiekt blok funkcyjny:
»function block”.

Function Block
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Propmbes - Funchion Block

Generdl: Pait1 | Genaral- Pat2 | Atpiutes |

Sewrbei
Syl comment:

Mowe [hsmall Fi)
-

Faciect pach |

Sorage localion

of project:
Lol

07 1038 134208
071038 124208

Date crmaledt
Lzt modifet

E\SIEHENEKS'IEP?\E TerovEchin_1

I [

071088134208

Podwdjne klikniecie na blok FB1
powoduje otwarcie go w
edytorze LAD/STL/FBD.

W okienku ,Properties-Function
Block” wybierz spos6b
prezentacji programu, w jakim
chcesz edytowac blok, oraz
aktywuj opcje ,,Multiple
instance FB”. Na koncu
zatwierdz OK.

Blok FB1 pojawi sie w folderze
blokéw.

W zaleznosci od tego, ktory jezyk programowania wybrates, kontynuuj dalsze
dziatania zgodnie z rozdziatem: 5.2 — schemat drabinkowy LAD, 5.3 — lista

instrukcji STL lub 5.4 - bloki logiczne FBD.

Dalsze informacje znajduja sie w
Help>Contents pod hastem ,Programming
Blocks” i ,Creating Blocks and Libraries”.
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5.2 Programowanie FB1 w schemacie drabinkowym

Stworzymy blok funkcyjny sterowania i monitorowania stanu paliwa silnika
dieslowskiego z uzyciem dwdch réznych blokéw danych.

Wszystkie sygnaty charakterystyczne dla silnika przekazywane sa jako
parametry bloku funkcyjnego, dlatego tez nalezy je zdefiniowa¢ w czesci
deklaracyjnej bloku jako parametry wejsciowe lub wyjsciowe.

Powinienes takze do tej pory opanowaé wprowadzanie potaczenia
szeregowego, rownolegtego i funkcji pamietania.

1. Wypelnianie tabeli deklaracji parametréw
e A AL - O.twieramy edytor programu iw menu
Di{2R) &) f[ef <[] Cisl [ View wybieramy sposéb prezentacji w
DT T TS . f
1 P schemacie drabinkowym LAD.

W nagtowku znajduje sie oznaczenie
bloku FB1, ktéry zostat otwarty do
edyciji.

o B [ e Y T~ T S T Ty a1
ot 11 4 e e & Hal Lat [

Obszar deklaracji zmiennych zawiera okno przegladu zmiennych (lewa czesé)
i okno doktadnych informacji (prawa czesc).

W oknie przegladu zmiennych nalezy kolejno wybra¢ typ "IN”, "OUT” i "STAT”,
a nastepnie zdefiniowa¢ zmienne w oknie szczegotowym.

Zdefiniuj zmienne wedtug rysunkéw umieszczonych ponizej. Typy zmiennych
sg definiowane za pomocg rozwijane;j listy.
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Switch off engine
Engine failure, causes the engine to switch off
1} Actual engine speed

‘& [Engine_0On
‘@ Preset_Speed_Reached (Bool

Preset speed reached

41

‘2 [Preset_Speed
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2. Programowanie zataczania i wylaczania silnika

Uzywajac odpowiednich klawiszy z

listwy narzedziowej, lub katalogu
elementéw programowych
wprowadz do sieci 1 styk normalnie
rozwarty, styk normalnie zwarty oraz
element SR.

22.?

SR Nastepnie wybierz wejscie R.

R | Wprowadz kolejny styk normalnie

Display » v Symbolic Representation Chrl+0

v Comments Clrl+Ehift+K

rozwarty na wejscie R.

-M-I T I Nastepnie wprowadz rownolegle
styk normalnie zwarty uzywajac
wymienionych obok klawiszy.

Sprawdz, czy wybrana jest

SymbolIrfomation  CtlsShift+Q reprezentacja symboliczna.

Symbol Selection Clr+?

Wybierz pole ze znakami zapytania i wprowadz odpowiednig nazwe z tabeli
deklaracji (znak # wprowadzany jest automatycznie).

Wprowadz nazwe ,Tryb automatyczny” (,Automatic Mode”) nad stykiem
normalnie zwartym w potaczeniu szeregowym.

#owditch on

fAubtomakbic #Engine_On

_mMode" =R

#Switch oOf
£
| 1

1 s a

#FPailurs

L7

Parametry lokalne poprzedzane sg znakiem # i
obowigzujg jedynie w ramach danego bloku.
Zmienne globalne umieszczone sg w cudzystowach.
Nazwy te zdefiniowane sg w licie symbolicznej i
obowigzujg w catym programie.

Stan sygnatu , Tryb Automatyczny” (,Automatic
Mode”) ustalany jest w bloku OB1 (spojrz str.26), a
teraz w FB1 tylko odpytywany.
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3. Programowanie kontroli predkosci

Whprowadz kolejna sie€ i zaznacz
biezgca Sciezke.

Z katalogu elementdéw wybierz w
grupie ,,Compare” instrukcje GE_I.

Do biezacej sieci dodaj takze cewke.

Zaznacz ponownie znaki zapytania i wprowadz etykiety dla cewki oraz wej$é
funkcji poréwnania uzywajac nazw z tabeli deklaracji.

H#Preset_sSp
eed_Reache
CMP ==1 d
{ —
HActual_Sp
eed —IN1

H#Preset Sp
ead —INZ

Kiedy silnik jest zatagczany i wytaczany?

Jesli zmienna #Switch On ma warto$¢ 1 i sygnat ,Automatic Mode” ma warto$¢ 0,
silnik jest wigczany. Negacja sygnatu ,Automatic Mode” (styk normalnie zwarty)
zapewnia takie dziatanie.

Jesli sygnat #Switch Off jest ustawiony na 1 lub sygnat btedu #Failure jest 0, silnik
jest wytaczany. Takie funkcjonowanie zapewnione jest réwniez dzieki negacji. W
normalnej sytuacji sygnat #Failure na stan 1, natomiast w sytuacji awaryjnej
przyjmuje stan O.

Jak kontrolowane s3 obroty silnika poprzez funkcje poréwnania?
Porownywane sg dwie wartosci: aktualna #Actual_Speed, oraz zadana
#Preset_Speed. Wynik poréwnania przekazywany jest do bitu potwierdzenia
poprawnosci pracy #Preset_Speed_Reached (stan sygnatu 1).

Dalsze informacje znajdujg sie w
Help>Contents w temacie "Programming
Blocks”, ,,Creating Logic Blocks” oraz ,Editing
the Variable Declaration Table” lub tez
sEditing LAD Instruction”.
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5.3 Programowanie FB1 w liScie instrukcji

Stworzymy blok funkcyjny sterowania i monitorowania stanu paliwa silnika
dieslowskiego z uzyciem dwdch réznych blokéw danych.

Wszystkie sygnaty charakterystyczne dla silnika przekazywane sg jako
parametry bloku funkcyjnego, dlatego tez nalezy je zdefiniowa¢ w czesci
deklaracyjnej bloku jako parametry wejsciowe lub wyjsciowe.

Powinienes wiedzie¢, jak w STEP7 wprowadzi¢ instrukcje AND, lub OR, czy
tez set/reset.

1. Wypelnianie tabeli deklaracji parametréw

(L0 /S TLAHD - [F) - Gaiiing ELansd SIMATIC 00 Slatn\CPUS1 AT | K

Otwieramy edytor programu i w menu
View wybieramy sposéb prezentacji w
liscie instrukcji STL.

W nagtéwku znajduje sie oznaczenie
_____ 3  bloku FB1, ktdry zostat otwarty do
Bean BE- L L edycji.

| (01 = M T 10 = === S " F e
Thans 71 ra ek © e il Ll oo

Wprowadz deklaracje w tabeli. Nalezy wzorujac sie na ponizszych tabelach, w
odpowiednie komorki wprowadzi¢ nazwe parametru, jego format, a takze
komentarz do parametru. Typ parametru mozna wprowadzi¢ wpisujac jego
nazwe, lub tez uruchomic¢ okienko typéw prawym klawiszem myszy, ktérym
mozemy wybraé typy podstawowe: ,Elementary Types”. Jedli zadeklarujesz
juz wszystkie pola dotyczgce zmiennej, zatwierdz to klawiszem ENTER.

Contents O, EnvironmentynterfacetN'

[ |piaseng [MNarme Data Type|Address [Initial Value|Camment
3 @ ‘= (Switch_On |Boaol 0.0 FALSE Switch on engine
S = Switch_Of  |Bool 0.1 FALSE Switch off engine
TFINOUT g Failure Bool 0.2 FALSE  Engine fallure, causes fhe engine 1o switch off
= g ;;ﬁ: = Actual_Speed|Int 20 0 Actual engine speed

Contents OF ‘Environment\Interface\DUT'

@ Inteiface ‘Nsme Data Type |Address Initial Value ‘Cﬂmment
+ ‘= |Engine_on Bool 4.0 FALSE Engine is switched on
* '@ Preset_Speed_Reached |Bool 41 FALSE Preset speed reached
el o
+ i STAT
& TEMP

k} Contents OF. ‘Environment\Interface\STAT'

= Inteiface |Mame Diata Type|Address|Initial Value| Comment

S m | = [Presel_Speed|int 6.0 1500 Requested endine speed
v Ok OUT

ik T
+ @ Nazwy zmiennych moga sktadaé sie
jedynie z liter, cyfr i podkreslen.
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2. Programowanie zataczania i wylaczania silnika

Sprawdz, czy wybrana jest
reprezentacja symboliczna.
Display » » Symbolic Representation Ctrl+0)

Symbal [nformation Ctrl+Shift+Q

Symbaol Selection Clrl+7
v Comments Crl+Shift+

Whprowadz instrukcje programu do
A #3witch _On sieci 1.

AN "Automatic Mode"

3 #Engine On
#8witch Off

ON #Failure

R #Engine On

Parametry lokalne poprzedzane sg znakiem # i obowigzujg jedynie w
ramach danego bloku.

Zmienne globalne umieszczone sa w cudzystowach. Nazwy te
zdefiniowane sa w licie symbolicznej i obowiazujg w catym
programie.

Stan sygnatu ,Tryb Automatyczny” (,Automatic Mode”) ustalany jest w
bloku OB1 (patrz str.29), a teraz w FB1 tylko odpytywany.

3. Programowanie kontroli predkosci
Wprowadz nowg sie€ oraz instrukcje

5 #Actual Speed programu. Nastepnie zapisz
L #Preset_Speed stworzony blok.
=1

= #Preset Speed Reached

Kiedy silnik jest zatagczany i wytaczany?

Jesli zmienna #Switch On ma warto$¢ 1 i sygnat ,Automatic Mode” ma warto$¢ 0,
silnik jest wigczany. Negacja sygnatu ,Automatic Mode” (styk normalnie zwarty)
zapewnia takie dziatanie.

Jesli sygnat #Switch Off jest ustawiony na 1 lub sygnat btedu #Failure jest 0, silnik
jest wytaczany. Takie funkcjonowanie zapewnione jest rowniez dzieki negacji. W
normalnej sytuacji sygnat #Failure na stan 1, natomiast w sytuacji awaryjnej
przyjmuje stan O.

Jak kontrolowane sa obroty silnika poprzez funkcje poréwnania?
Porownywane sg dwie wartosci: aktualna #Actual_Speed, oraz zadana
#Preset_Speed. Wynik poréwnania przekazywany jest do bitu potwierdzenia
poprawnosci pracy #Preset_Speed_Reached (stan sygnatu 1).

Dalsze informacje znajdujg sie w
Help>Contents w temacie”’Programming
Blocks”, ,,Creating Logic Blocks” oraz ,Editing
the Variable Declaration Table” lub tez
,Editing STL Instruction”.
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5.4 Programowanie FB1 w blokach logicznych

Stworzymy blok funkcyjny sterowania i monitorowania stanu paliwa silnika
dieslowskiego z uzyciem dwdch réznych blokéw danych.

Wszystkie sygnaty charakterystyczne dla silnika przekazywane sg jako
parametry bloku funkcyjnego, dlatego tez nalezy je zdefiniowa¢ w czesci
deklaracyjnej bloku jako parametry wejsciowe lub wyjsciowe.

Powinienes wiedzieé, jak w STEP7 wprowadzi¢ funkcje AND, lub OR, czy tez
tez funkcje pamietania.

1. Wypelnianie tabeli deklaracji parametréw

L‘.‘f LAD /STLAFBD - [FB -- Gotting Started\SIMATIC 300 Siation\CPUI1A[11]

O Fle Ed jusot FLC [obug Mow Optons Windw Hep 167 % . .

Ol @) ole] || i [ Otwieramy edytor programu i w menu
S B View wybieramy sposdb prezentaciji w

artents U Lowiormer Mlrlzrace’
L

e
QU
i pon

liscie instrukcji FBD.

=l
5 W nagtéwku znajduje sie oznaczenie

bloku FB1, ktory zostat otwarty do
edycji.

r |

[AETRDI. T A 20 A 3 Conelelmenn: ATl Ty
Fress F1 ko et Hop, 9 ol b Tl Ll Ineat

Wprowadz deklaracje w tabeli. Nalezy wzorujac sie na ponizszej tabeli, w
odpowiednie komorki wprowadzi¢ nazwe parametru, jego format, a takze
komentarz do parametru. Typ parametru mozna wprowadzi¢ wpisujgc jego
nazwe, lub tez uruchomic¢ okienko typéw prawym klawiszem myszy, ktérym
mozemy wybra¢ typy podstawowe: ,Elementary Types”. Jesli zadeklarujesz
juz wszystkie pola dotyczgce zmiennej, zatwierdz to klawiszem ENTER.

Contents OF ‘ErvironmenttInterface M’

I | : [Mame Data Type [Address|initial Value[Comment
+ @ ‘= |Switch_On  |Bool 0.0 FALSE Switch on engine
+- ey ‘= Switch_Off  |Bool 01 FALSE Switch off engine
hnd !_'*—DUT ‘= Failure Bool 0.2 FALSE Engine fzilure, causes the engine to switch off
T g ;;:1-{: :_?IJ Actual_Speed|Int 2.0 0 Actual engine speed
Contents OF ‘Ervironment'Interface\0UT"
0 Interface [Narne Data Type [Address [Inifial Value  [Comment
+ = |Er'\gir'\e_tm Bool 4.0 FALSE Engine is switched an
ks @ ‘@ Presel_Speed_Reached |Bool 4.1 FALSE Preset speed reached
FEOUT |
+ I STAT
& TEMP
lﬁ} Contents OF 'Environmentilnterface\STAT'
3 Irterface [Name Data Type|Address|Initial Value[Comment
+ 0 IN Int 6.0 1500 Requested engine speed
+ 0= 0UT ]
L) T
+ . , .
& Nazwy zmiennych moga sktadaé sie

jedynie z liter, cyfr i podkreslen.
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2. Programowanie zataczania i wylaczania silnika

i XD _aaz Wprowadz funkcje SR do sieci 1
o C=) uzywajac katalogu funkgji (folder Bit
2. 72— —69 Logic).

Dodaj funkcje AND na wejscie S,
oraz funkcje OR na wejscie R.

22, 72—

22,7 — —@ Q=
| Sprawdz, czy wybrana jest
T i ¥ B R CG reprezentacja symboliczna.
Symbol |nformation Ctrl+Shift+Q
Symbol Selection Chil+7
v Comments Clel+Shift+K.

Wybierz pole ze znakami zapytania i wprowadz odpowiednig nazwe z tabeli
deklaracji (znak # wprowadzany jest automatycznie).

Jedno z wejs¢ funkcji AND nalezy zadeklarowa¢ jako ,Automatic_Mode”.

Wykorzystujac odpowiedni klawisz listwy narzedziowej zaneguj wejécia
LJAutomatic_Mode” oraz #Fault.

Nastepnie zabezpiecz blok.

&
#Switch On —

B #Engine On
"Automatic SR
_Mode" =} —

=1
#3witch Of
i —_—
#Failure =} — Q-

Parametry lokalne poprzedzane sg znakiem # i obowigzujg jedynie w
ramach danego bloku.

Zmienne globalne umieszczone sg w cudzystowach. Nazwy te
zdefiniowane sg w licie symbolicznej i obowigzujg w catym
programie.

Stan sygnatu ,Tryb Automatyczny” (,Automatic Mode”) ustalany jest w
bloku OB1 (patrz str.33), a teraz w FB1 tylko odpytywany.
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3. Programowanie kontroli predkosci

Whprowadz kolejng sie¢ i zaznacz
biezgca Sciezke.

Z katalogu elementdéw wybierz w
grupie ,Compare” instrukcje GE_LI.

Dodaj funkcje przepisania wyniku, a nastepnie oznacz symbolami wejscia i
wyjscie funkcji.

Nastepnie zapisz blok.

CMP ==I
#ictual Sp #Preset Sp
sad [ T eed Reache
d
#Preset Sp =
eed — INZ L

Kiedy silnik jest zalagczany i wytaczany?

Jesli zmienna #Switch On ma warto$¢ 1 i sygnat ,,Automatic Mode” ma wartos¢ 0,
silnik jest wigczany. Negacja sygnatu ,Automatic Mode” (styk normalnie zwarty)
zapewnia takie dziatanie.

Jesli sygnat #Switch Off jest ustawiony na 1 lub sygnat btedu #Failure jest 0, silnik
jest wytaczany. Takie funkcjonowanie zapewnione jest réwniez dzieki negacji. W
normalnej sytuacji sygnat #Failure na stan 1, natomiast w sytuacji awaryjne;j
przyjmuje stan 0.

Jak kontrolowane sa obroty silnika poprzez funkcje poréwnania?
Porownywane sg dwie wartosci: aktualna #Actual_Speed, oraz zadana
#Preset_Speed. Wynik poréwnania przekazywany jest do bitu potwierdzenia
poprawnosci pracy #Preset_Speed_Reached (stan sygnatu 1).

Dalsze informacje znajdujg sie w
Help>Contents w temacie’Programming
Blocks”, ,,Creating Logic Blocks” oraz ,Editing
the Variable Declaration Table” lub tez
»Editing LAD Instruction”.
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5.5 Tworzenie lokalnego bloku danych oraz aktualizacja wartosci

Przed chwilg zostat zdeklarowany blok FB1. Zdefiniowalismy takze w tabeli
deklaracji jego parametry.

By méc potem wywotac ten zdefiniowany blok w bloku OB1, nalezy wczes$niej
stworzy¢ przypisany do niego blok danych. Tego typu blok nazywany bedzie
blokiem danych lokalnych i uzywany w powigzaniu z blokiem funkcyjnym, dla
ktorego zostat zdefiniowany.

Blok funkcyjny steruje i nadzoruje prace silnika. Rozne warto$ci predkosci
zadanej sg zapamietane w dwéch réznych blokach danych, w ktérych mozna
je aktualizowaé.

Dzieki temu, ze blok funkcyjny programowany jest tylko jeden raz,
oszczedzamy pamieé sterownika.

W SIMATIC Manager otwarty jest

| m;" Ll B nasz projekt (np."Getting Started”).
T Nalezy wej$é w folder Blocks i
- O kliknaé prawym klawiszem myszy

na prawej czesci okna.

‘ Teraz mozna wprowadzi¢ nowy

T blok wybierajac z okienka Data
Block.
TR Wprowadzi¢ DB1 oraz wybrac

| sinstance DB” do bloku
funkcyjnego FB1

Properties - Data Block

Genwal-Pat 1 | General Part2 | Cale | Attibutes |

Hemeondyp: 061 (e | =l | Nalezy zatwierdzi¢ wszystkie
= e e ustawienia w okienku Properties
R za pomoca klawisza OK.
Created in Language: DB A
P W‘m_ —— Blok danych DB_1 dodawany jest
ol Pkt A do naszego projektu.
Larodas  mAvmboscs  mamm s Kliknij podwdjnie by otworzy¢ DB1,
Comment: =
=
' Cancel Help
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Dpen Data Block

By default, instance data blocks are opened with "Parameter assignment
i far data blacks™ &3 of STEP 75,2 [32& Help)

\‘) There is ho functional difference for this DB to the editor in
LAD/STLAFBD

The DB could be opened with the DB editor in LAD/STLAFBD [as in
W8.1).

Do you want to open the DB wih "Parameter assighment for data
blocks"?

¥ Always display this meszage for Dpen Instance DB

Help

Ot vk | Acksd valia Corovart
Pt
FASE
(e
o

SEESERE:

Intialvale | Achud vaks | Commant

“untzh o g
Sustch o argm
i

FESERES
5

Nalezy zatwierdzi¢ okno dialogowe
przypisania parametrow lokalnego
bloku danych.

Nastepnie w kolumnie wartosci
aktualnych ,Actual Value” w wierszu
predkosci zadanej (,Setpoint Speed”)
wprowadzmy wartos¢ 1500. W ten
sposoéb zdefiniowali§my maksymalng
predkos¢ tego silnika.

Teraz zapamietujemy blok i zamykamy
okno edytora.

W ten sam sposéb definiujemy blok
DB2 (,Petrol”) wprowadzajac jako
wartos¢ zadang predkosci liczbe 1200.

W tym momencie zakonczylismy definiowanie blokéw potrzebnych do sterowania
dwoma silnikami za pomoca jednego bloku funkcyjnego. By dodaé kolejne silniki
wystarczy po prostu zdefiniowaé kolejne bloki danych.

Nastepnym naszym krokiem bedzie wywotanie bloku FB1 w bloku gtéwnym OB11.
By wykona¢ to w schemacie drabinkowym przeczytaj rozdziat 5.6, w liscie
instrukcji rozdziat 5.7, a w schemacie blokéw logicznych rozdziat 5.8.

Wiecej infomacji znajduje sie w

Help>Contents w tematach

.Programming Blocks” oraz ,Creating Data

Blocks”.
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5.6 Programowanie wywotania bloku w schemacie drabinkowym

Wszystko, co do tej pory zostato stworzone, bedzie bezuzyteczne, dopdki nie
wywotamy bloku FB1 w OB1. Blok FB1 wywotywany jest dwa razy,
kazdorazowo z innym blokiem danych.

:l:l- Engne: M It

& Getbng Slasted — CASILMENSYS LCROS foio VG othin_1

DB1
Petrol Engine
Data
FB1

DB2

Diesel Engine
Data

Tt

W SIMATIC Manager otwarty jest
nasz projekt (np. ,Getting Started”).

Nalezy klikajac dwukrotnie otworzy¢
blok OB1.

Nalezy stworzy€ sie¢ 4, a nastepnie

poruszajgc sie po katalogu
elementéw w folderze FB Blocks
znalez¢ blok FB1 i dotozyé go do
OB1.

: W miejsca wejs¢ funkcji nalezy
i | wprowadzi¢ styki normalnie
) rozwarte.
Nalezy nastepnie zaznaczy¢ ?7??
nad blokiem, a nastepnie trzymajac

e apad . w tym samym miejscu kursor,

nacisnaé prawy klawisz myszy.

W dodatkowym oknie menu nalezy
wybra¢ Insert Symbol. Pojawi sie
@ il Jista elementéw symbolicznych
dostepnych w programie. Czynnos$¢

ta wykonywana po raz pierwszy
moze by¢ nieco czasochtonna.
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[ ]
(FPeuc) FE 1 DB

1

Diata for petral enai

Wybierajac blok ,Petrol”
spowodujemy automatycznie
powigzanie tego wywotania bloku
funkcyjnego FB1 z blokiem danych
dla silnika benzynowego.

Wstaw adresy symboliczne dla wszystkich parametréw uzytych dla tej funkcji
poruszajgc sie po dostepnej liscie symboliczne;.

"Petrol”

"Switch On PET
| |

"Switch OEf PE"
| |

"PE_Failure”

"PE_Actual Speed”

EN

Fwmitch On

Switch Off

Failure

Actual Speed

"Engine"

(e
o/

ENO
Engine Oni—"pE on"

Preset Speed Reac| "pE Preset Speed R
hed eached™

48

Wejscia i wyjécia funkcji
wyswietlane sg teraz jako jej
parametry.

Zostang im przypisane
sygnaty charakterystyczne
dla silnika benzynowego
SPE_xxx".



Nalezy zaprogramowac w kolejne sieci wywotanie bloku FB1 z uzyciem bloku

danych ,Diesel’ DB2,

oraz nada¢ adresy uzywajac listy rozwijalnej.

"Diesel"”

"Switch On DEY
| |
I

"Switeh Off DET
|

"DE_Failure”
| |

"DE_Actual Speed” —

"Engine™
EN ENO

Engine_On-—"DE on'

Switch on
Preset Speed Reac "DE Preset Speed R
hed [—eached"”
Switch Off
Failure Wszystkie sygnaty
przyporzadkowane
actual Speed silnikowi diesela

oznaczane sg ,DE_xxx”

E | Zapamietaj program i zamknij blok.

Jesli tworzymy program, w ktérym wykorzystywane sa bloki organizacyjne,
funkcyjne czy bloki danych, powinnismy stworzy¢ wywotanie bloku
podporzgdkowanego w bloku wyzszym. Ta zasada obowigzuje we wszystkich

tego typu przypadkach.

W tablicy symbolicznej nazywa¢ mozemy takze poszczegoine bloki programu.

Jednocze$nie mozliwy jest

wydruk i archiwizacja stworzonych blokéw. Te

mozliwosci znajdujg sie w menu File>Print lub File>Archive.

Wiecej infomacji znajduje sie w
Help>Contents w tematach ,Calling
Reference Helps” oraz ,Language
Description: LAD” i ,,Program Control
Instruction”.
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5.7 Programowanie wywotania bloku w liscie instrukcji

Wszystko, co do tej pory zostato stworzone, bedzie bezuzyteczne, dopdki nie
wywotamy bloku FB1 w OB1. Blok FB1 wywotywany jest dwa razy,
kazdorazowo z innym blokiem danych.

FB1
"Engine"

L t—=—%

CALL "Engine" , "Petrol”

Switch On

Switch Off

Failure

Actual Speed

Engine On :
Preset Speed Reached:

HH
| LT
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DB1
Petrol Engine
Data

DB2

Diesel Engine
Data

T+

W SIMATIC Manager otwarty jest
nasz projekt (np. ,Getting Started”).

Nalezy klikajac dwukrotnie otworzy¢
blok OB1.

Nalezy stworzyé sie¢ 4.

Wprowadz instrukcje CALL
»Engine”, ,,Petrol”.

Wyswietlajg sie wszystkie parametry
uzytego bloku funkcyjnego. Najedz
na pozycje = parametru Switch_On,
i naciénij prawy klawisz myszy.

W dodatkowym oknie menu nalezy
wybra¢ Insert Symbol. Pojawi sig
lista elementow symbolicznych
dostepnych w programie. Czynnos$¢
ta wykonywana po raz pierwszy
moze by¢ nieco czasochtonna.



S e oo Wybierajac blok ,Petrol”

5] PE_ctual Speed INT [ : : .
Breae son o= spowodujemy automatycznie
%SE:EZ"”'”” o powigzanie tego wywotania
@I;;;veselﬁueed,ﬁeeched IlzBUEIL1 EB 5 bloku funkcyjnego FB1 Z

) Red_Light BOOL 0§ & . oo

9 suioh e CRRI blokiem danych dla silnika
Swih 01 E BOOL | 11

BOOL |1 1. benzynowego.

Wstaw adresy symboliczne dla

CALL, "Engine™ , "Petrol”

Switch On :="Switch_On PE" wszystkich parametréw uzytych
Switch Off :="Switch Off PE" dla te] funkcji poruszajqc Sle po
Failure :="PE_Failure"” Ces . .
Actual Speed :="PE:hctual_Speed" dOStepneJ IISCIe Symbo“cznej'
Engine_om ="PE_On"
Preset_Speed_Resched:="PE_Preset_Speed Reached
Wszystkie sygnaty
przyporzadkowane

silnikowi diesla
oznaczane sg ,DE_xxx”

¢ALL "Engine" , "Diesel” Nalezy zaprogramowaé w
Switeh On 1="Switch_On_DB" kolejne sieci wywotanie bloku
switch_Off 1="switch_Off_DE"

FB1 z uzyciem bloku danych

Failure ="DE_Failure" i " ,
Actual Speed ="DE Actual Speed"” ,,D|ese| DBZ, oraz nadaC
Engine_On +="DE_Cn" adresy UZyWaJa_C ||Sty

Preset Speed Reached:="DE Preset Speed Resached” " .
- n = - . rozwijalne;j.

H Zapamietaj program i zamknij
— blok.

Jesli tworzymy program, w ktérym wykorzystywane sg bloki organizacyjne,
funkcyjne czy bloki danych, powinnismy stworzy¢ wywotanie bloku
podporzgdkowanego w bloku wyzszym. Ta zasada obowigzuje we wszystkich
tego typu przypadkach.

W tablicy symbolicznej nazywac¢ mozemy takze poszczegolne bloki programu.

Jednoczes$nie mozliwy jest wydruk i archiwizacja stworzonych blokéw. Te
mozliwosci znajdujg sie w menu File>Print lub File>Archive.

Wiecej infomaciji znajduje sie w
Help>Contents w tematach ,Calling
Reference Helps” oraz ,Language
Description: STL” i ,,Program Control
Instruction”.
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5.8 Programowanie wywotania bloku w schemacie blokéw
logicznych

Wszystko, co do tej pory zostato stworzone, bedzie bezuzyteczne, dopdki nie
wywotamy bloku FB1 w OB1. Blok FB1 wywotywany jest dwa razy,
kazdorazowo z innym blokiem danych.

DB1
Petrol Engine
Data

i
D ——>71 } M B2

Diesel Engine
Data

Tt

W SIMATIC Manager otwarty jest
nasz projekt (np. ,Getting Started”).

Nalezy klikajac dwukrotnie otworzyé
blok OB1.

Nalezy stworzy€ sie¢ 4, a nastepnie
poruszajac sie po katalogu
elementéw w folderze FB Blocks
znalez¢ blok FB1 i dotozy¢ go do
OB1.

\ii// Pokazane sg wszystkie parametry
..—En wejsciowe i wyjsciowe.
.. —{switeh_on Nalezy nastepnie zaznaczy¢ ?7??
Engine Onj= . . .
[ o namEME... nad blokiem, a nastepnie trzymajac
Preset Speed Reac w tym Samym m|eJSCU kUI’SOI',
T b oo ~---  nacisnag¢ prawy klawisz myszy.
.. —lActual Speed ENO =

W dodatkowym oknie menu nalezy
wybrac Insert Symbol. Pojawi sie
Insert Syrbal Ctilsl : . .
C&mum Q ‘ lista elementow symbolicznych
dostepnych w programie. Czynnos$¢
ta wykonywana po raz pierwszy
moze by¢ nieco czasochtonna.
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Woybierajac blok ,Petrol”
I spowodujemy automatycznie

@ 0 FBE 1 DB 1  Datafor petrol enagi pOWquanle tegO WyWOI'anla b|0kU
funkcyjnego FB1 z blokiem danych
dla silnika benzynowego.

Wstaw adresy symboliczne dla wszystkich parametréw uzytych dla tej funkcji
poruszajac sie po dostepnej liscie symboliczne;.

"Petrol”

"Engine"

. == EN

"Switch On PE" —Switch_On
- - Engine On|—"pg on"
"Switch Off PE" —Switch Off =
e Preset_Speed Feac| "PE Preset Speed R
"PE_Failure” —Failure hed L cached” >

?E Actual Speed” ——Actual Speed ENO (-~

Wejscia i wyjscia funkciji
wyswietlane sg teraz jako jej
parametry.

Zostang im przypisane
sygnaty charakterystyczne
dla silnika benzynowego
SPE_Xxx".
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Nalezy zaprogramowac¢ w kolejne sieci wywotanie bloku FB1 z uzyciem bloku
danych ,Diesel” DB2, oraz nadac adresy uzywajac listy rozwijalne;.

"Engane"

.. —EN

"Switch_On_DE" == Switch On
Engine_On—"pE On"
"Switch Off DE"™ —Switc h_Off

Preset_Speed Reac| "DE Preset Speed R
"DE_Failure” —Failure hed ~eached"”

"DE_Actual Speed” —Actual Zpeed ENC =

Wszystkie sygnaty
przyporzadkowane
silnikowi diesla
oznaczane sg ,DE_xxx"

Hl Zapamietaj program i zamknij blok.

Jesli tworzymy program, w ktérym wykorzystywane sg bloki organizacyjne,
funkcyjne czy bloki danych, powinnismy stworzy¢ wywotanie bloku
podporzgdkowanego w bloku wyzszym. Ta zasada obowigzuje we wszystkich
tego typu przypadkach.

W tablicy symbolicznej nazywac¢ mozemy takze poszczegolne bloki programu.

Jednoczes$nie mozliwy jest wydruk i archiwizacja stworzonych blokéw. Te
mozliwosci znajdujg sie w menu File>Print lub File>Archive.

Wiecej infomacji znajduje sie w
Help>Contents w tematach ,Calling
Reference Helps” oraz ,Language
Description: FBD” i ,,Program Control
Instruction”.
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Konfiguracja jednostki podstawowej

Konfiguracja sprzetowa

Przeprowadzenie konfiguracji sprzetowej jest mozliwe wtedy, gdy zatozona
zostata stacja SIMATIC. Struktura projektu zostata zdefiniowana w
rozdziale 2.1.

Konfiguracja sprzetowa tworzona jest w STEP7 i przenoszona do sterownika
za pomocg funkcji ,Download”. (patrz. Rozdz. 7).

&5 Betling Started - CASIFMEHSAPEEYT

i\ nitin_1

CRUT4

LCE Punktem wyjscia jest otwarty
SIMATIC Manager wraz z projektem
,aetting Started”.

Otwoérz katalog SIMATIC 300-
Station i kliknij dwukrotnie na

symbol Hardware.

Otworzy sie okno "HW Konfig”. Ukaze sie jednostka centralna wybrana przy
zaktadaniu projektu. Dla projektu ,Getting Started” jest to CPU 314.

E—,_'_I IW nnfig - [5IMATIC JN0 Dkadion

ian) -- Getting Nitealed]

B G- _dk Inser [L Wiew Upions lep =gl
I e N = T =l = A
_ fl Peik [l =
ij‘ E-m LI Iy N By Ty
Z [cruzan | EE SIMAT = 300
, . 1 SIMAT 2 a0
Rack z poszczegbinymi i SHAT 2 FC Based Centl
, pozycjami modutéw
B o Katalog
o UF sprzetowy
ST i T | Uit B L ML aduesy | Aol | D | Lo werd |
i R EEST 214 15E0< (=B0 2

oo DT b r =

=]

T

Tabela konfiguracyjna z
adresami modutéw i MPI

Krotka informacja o

zaznaczonym elemencie

Tl ben

FIFELZ D2 dovexfa SIMATIC 5T, M7,
ortd 7 [ehioubon k)

Pomoc do zaznaczonych
elementow L
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N -
=-[BH) SIMATIC 300
=21 PS-300

F scirge)
+|nwn
- [E SIMATIC 300

=1+ 5M-300

= B

- DI-300

E SM321 DI3ZeDC24Y

=-1 DO-300

[§ 5M322 DO32DC24Y /058

W pierwszej kolejnosci potrzebne
jest zasilanie. Znajdz w katalogu
PS307 2A i wprowadz metoda
Drag and Drop w pozycje 1.

Wyszukaj modut wejsciowy
(DI, Digital Input) SM321
DI32xDC24V i wprowadz go w
pozycje 4. Pozycja 3 pozostaje
wolna.

Analogicznie wprowadz na pozycje
5 modut wyjsciowy SM322
D0O32xDC24V/0.5A.

Aby zmieni¢ parametry modutu w ramach projektu, otworz je klikajac
podwdijnie na modut. Parametry moga by¢ zmieniane jedynie wtedy, gdy
jestes catkowicie pewien, jaki wptyw beda miaty te zmiany na sterownik.

Dla projektu ,Getting Started” zmiany nie sa konieczne.

Slat B Module Order Humber MP Address IAdd.. | O.. | Comment
1 [[] PS307 24 GES7 307-1BADC-0440
2 [ cru3t4(1) BEST 314-1AE04-04B0 2

[§ Dizzenc2ay GES7 321-1BLO0-0&AD 0.3

[d DO32DC24v/058  [GEST 322-1BLOD-OAAD

==

Statian

Coun

Save and Compile

Dane zapamigtane za pomocg Save
and Compile przygotowane sg do
przekazania do CPU.

Po zakonczeniu ,HW Konfig”
stworzona konfiguracja wystepuje jako
System Data w folderze Blocks.

Dodatkowo mozliwe jest sprawdzenie poprawnosci konfiguracji za pomocag
rozkazu z Menu Station >Consistency Check. W przypadku wystagpienia
btedéw STEP 7 proponuje mozliwe rozwigzania.

Wiecej informacji uzyskasz w Help >
Contents w ,, Configuring the Hardware” i
,configuring Central Rack”.
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7.1

tadowanie i testowanie programu

Ustanowienie potaczenia ze sterownikiem

Za pomocg zatgczonego projektu ,GS-LAD_Example” lub dotychczas
utworzonego ,Getting Started” pokazemy, w jaki sposéb mozna przestac
program do sterownika, a nastepnie go testowac.

Nalezy w tym celu:

» Posiadac¢ skonfigurowany sprzet w ,Getting Started” (patrz. rozdz. 6)

* Zbudowac¢ stacje sprzetowa zgodnie z dokumentacjg

Przyktad iloczynu logicznego (Funkcja AND):

Wyjscie Q 4.0 zapali sie (na module wyjs¢ cyfrowych zapala sie dioda Q 4.0),

jesli zostang wtaczone przetaczniki 1 0.1i | 0.2. Prosze zbudowac uktad
testowy za pomoca przewoddw na wiasnym sterowniku

Zasilanie Wigcznik trybu Szyna Programator

Wia/wyt pracy montazowa z
programem
STEP7

Kabel
programatora
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Montaz sterownika
Aby zamontowaé modut na szynie, prosze postepowac wg. wskazowek:

* Dotaczyé modut do tacznika szyny komunikacyjnej

* Zawiesi¢ modut i przechyli¢ w dét

*  Przymocowaé modut dokrecajac srube u spodu

e Zamontowaé pozostate moduty

* Po zamontowaniu wszystkich modutéw wtozyé kluczyk do CPU.

Test mozna tez przeprowadzié, jesli uzywasz innej konfiguracji sprzetowej niz
pokazana. Nalezy jednak uwazaé na prawidtowe adresowanie wejsc i wyjsé.

STEP 7 oferuje wiele mozliwosci testowych, np. test statusu programu lub test
zmiennych.

Wiecej informacji o konfiguracji jednostek
podstawowych uzyskasz w podreczniku
»37-300, Hardware and Instalation/Module
Specifikations” i ,S7-400/M7-400 -
Hardware”.
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7.2 tadowanie programu do sterownika

tadowanie programu jest mozliwe dopiero po utworzeniu potaczenia On-Line.

Zalaczenie zasilania

=

o

RUNP ——

RUN -
STOP

MRES —

Wigcz napiecie wytgcznikiem ON/OFF.
Zapali sie dioda ,DC 5V” na CPU.

Przekre€ przetacznik trybu pracy na
STOP (o ile nie jest juz przetgczony).
LED ,STOP” zapali sie na
pomaranczowo.

Kasowanie catkowite CPU i uruchomienie w tryb RUN

RUNP ——
RUN =

STOP e
MRES —

Kasowanie catkowite
powoduje usuniecie
wszystkich danych z CPU.
CPU znajduje sie w stanie
podstawowym.

Zatadowanie programu do CPU

RUNP

RUN  —
STOP

MRAES  m—

Ustaw przetacznik trybu pracy w pozyciji
MRES i przytrzymaj tak co najmniej 3
sek. dopoki LED ,,STOP” nie zacznie
migac powoli na pomaranczowo.

Pus¢ przetacznik trybu pracy i
najpozniej po 3 sek. znéw przekre¢ w
pozycje MRES . Jesli LED ,STOP”
szybko miga, oznacza to, ze CPU
zostato catkowicie wykasowane.

Jesli ,STOP” nie miga w taki sposob,
nalezy powtdrzyc¢ operacje.

Aby zatadowaé program ustaw
przetacznik trybu pracy ponownie na
STOP”.
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ﬁ""l Uruchom SIMATIC Manager ,
otwérz w SIMATIC Managerze

przez pole dialogowe ,Open” projekt
»aetting Started” (o ile nie jest juz
otwarty).

Wywotaj dodatkowo dla okna
,aetting Started Offline” okno
»aetting Started Online”. Status

Difline Offline/Online zaznaczony jest w
nagtowku zmiennym kolorem.

Przejdz w obu oknach do folderu
Blocks.

Okno ,Offline” pokazuje stan na PG,
okno ,Online” pokazuje stan na
CPU.

Pomimo catkowitego kasowania
w CPU znajduja sie funkcje
systemowe (SFCs). Nie trzeba
ich tadowa¢, nie mozna takze
ich skasowac.

PLC [P Zaznacz w oknie ,Offline” folder
Blocks, a nastgpnie zataduj
program do CPU wywotujac
PLC>Download.

Potwierdz polecenie przez OK.

Download CirlsL

W oknie ,Online” po zatadowaniu
widoczne beda bloki programowe.

Polecenie Menu
PLC>Download mozna
wywotac przez odpowiedni
klawisz listwy funkcyjnej lub
Menu kontekstu prawym
przyciskiem myszy.
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Wiaczanie CPU i sprawdzanie trybu pracy.

Ustaw przetacznik trybu pracy w

RUMP e potozenie RUN-P. Dioda ,RUN” zapali
RUN = sie na zielono, a zgasnie dioda ,STOP”.
qur?Es —_— CPU jest gotowe do pracy.

Jesli pali sie dioda RUN, mozna
zaczynac test programu.

Jesli pali sie nadal dioda STOP,
wystapit btad. Do zdiagnozowania btedu
uzyj bufora diagnostycznego.

tadowanie poszczegoéinych blokow

Aby w praktyce méc szybko zareagowac w przypadku wystapienia btedow,
mozna tadowac bloki do CPU pojedynczo wykorzystujac mechanizm Drag and
Drop.

Przy tadowaniu blokéw przetacznik trybu pracy na CPU musi by¢ ustawiony na
»,RUN-P” lub ,STOP”. Bloki zatadowane przy trybie pracy ,RUN-P” zostajg
natychmiast uruchomione. Nalezy przy tym pamietag, ze:

» Jesli poprawne bloki zostang nadpisane przez btedne, spowoduje to btedne
funkcje urzadzenia. Mozna tego unikngé przeprowadzajgc przed tadowaniem
test.

» Jesli nie przestrzegano kolejnosci tadowania blokéw — tzn: wpierw mniej
wazne, potem gtéwne — CPU przechodzi w tryb pracy ,STOP”. Mozna tego
unikna¢ fadujac caty program do CPU w odpowiedniej kolejnosci.

Programowanie Online

Dla celéw testowych moze zaistnie¢ w praktyce konieczno$¢ zmiany dopiero co
zatadowanych blokéw do CPU. W tym celu kliknij dwukrotnie na zadany blok w
oknie ,Online”, aby otworzy¢ okno programu KOP/AWL/FUP. Zaprogramuj blok
na nowo. Nalezy pamietac, ze zaprogramowany i przepisany modut zostaje
natychmiast uaktywniony w CPU.

Dalsze informacje znajdujg sie w Help >
Contents w rozdziatach "Establishing an
Online Connection and Making CPU Settings" i
"Downloading from the PG / PC to the
Programmable Controller."
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7.3

Testowanie programu - status bloku

Wykorzystujac funkcje status bloku mozna podglada¢ dziatanie programu.
Niezbednym do realizacji jest istnienie potgczenia Online z CPU. Jednostka
centralna powinna znajdowac sie w trybie RUN lub RUN-P. Program powinien

oczywiscie zosta¢ zatadowany do CPU.

%ﬂq Stabed - CASIEMENS\STEPTVS Tpmoi\ietiin | D) =inix|
=¥ > = e g i i
- Al System Data m om a2
S

it = =
sPca sFCn SRC22
10 £ ] =
SFLa S T Al

- =

s SFCE

Testowanie w LAD.

Testowanie w STL

|| ruo| sTa| standard |

a "Key 1" 0 0 i}
A "Key 2" o 0 1]
- "Green Light" o 0 1]

Testowanie w FBD
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Otworz OB1 w oknie projektowym
,Getting Started Online”.

Otworzy sie okno edytora
programowania LAD/STL/FBD.

Uaktywnij funkcje Debug>
Monitor.

Przetacznik szeregowy w sieci 1 w
LAD zostaje zaznaczony. Az do
styku 1 (I 0.1) zaznaczony jest
przeptyw pradu, tzn., ze tu
przytozone jest napigcie.

W STL w tabeli prezentowane sa:

- Wynik operacji logicznej (RLO)

- bit statusu (STA)

- stan akumulatora 1
(STANDARD)

Stan sygnatu oznaczony jest za
pomoca ,0” i ,1”. Linia przerywana
oznacza, ze nie jest spetniony
warunek potgczenia.

Przez Option>
Customize mozna
zmienia¢ sposob
przedstawienia w danej
postaci testowania.




3 [ &
"Rey 17 — "Green _Light”

1 | -
ey 2" —|

2][rro stA | Stendard

A "Key 1" 1 1 0
A "Key 2" 1 1 o
& 1 0

"Green Light"

Zatacz teraz na swoim modelu
testowym oba przetgczniki.

Na module wejsciowym zapalg sie
diody wejs¢ 10.1i10.2.

Na module wyjsciowym zapali sie
dioda wyjscia Q 4.0.

W postaciach graficznych LAD/FBD
mozemy obserwowaé zmiany stanu
stosujac inne kolory dla réznych
stanow.

W jezyku STL zmiany w uktadzie
sterowania sygnalizowane sg
zmianami warto$ci w tabeli w
kolumnach RLO i STA.

Zdeaktywuj Debug>Monitor i
zamknij okno.

Nastepnie w SIMATIC Manager
zamknij okno ,,Online”.

Nie zalecamy catkowitego tadowania obszernych programéw do CPU, poniewaz
utrudnia to zdiagnozowanie ewentualnego btedu z uwagi na zwiekszong ilos¢
zrodet btedu. Zalecamy za to, dla lepszej przejrzystosci, oddzielne tadowanie
poszczegolnych blokow i kazdorazowe ich testowanie po zatadowaniu.

Dalsze informacje w Help >

Contents w rozdziatach "Debugging"
i "Testing with Program Status."
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7.4 Testowanie dziatania programu z wykorzystaniem tabeli
zmiennych

Testujesz poszczegblne zmienne programu obserwujac je i sterujac nimi.
Warunkiem dziatania jest istnienie potaczenia Online z jednostkg centralng
bedaca w trybie RUN-P, oraz wczeséniejsze zatadowanie programu.

Podobnie jak przy obserwacji statusu programu mozesz obserwowaé w tabeli
zmiennych wej$cia i wyjscia sieci 1 (przetacznik szeregowy tzn. funkcja AND).
Dodatkowo mozesz testowac takze aktualng predko$é obrotowsg silnika z
funkcji poréwnania z bloku FB1.

Tworzenie tabeli zmiennych
: ; czm Punktem wyjscia jest znow SIMATIC
Manager z otwartym projektem
,aetting Started Offline”.

Przejdz do folderu Blocks i kliknij
prawym przyciskiem myszy na prawg
czese okna.

Wprowadz za pomoca Menu

Inesit Yok Ouiect kontekstu Variable Table.

Propeutes - Varisbie Table Przejmij ustawienia wstepne

General-Pot | | Genesol Port 2| Abuses | ZamYKanC pOle dialogowe
Haems ATl A ” |
T EEE— ~Properties” klawiszem OK.
Symbol Comment: [
Project path [
o iz [ S SIS TGt 1
Code Interdace
Date crested CIN0/2002 0327 26
Last modbed D9A0/200 (32726 09102002 (32726

Comment ‘ _|

sy W katalogu blokéw zatozona zostaje
VAT1 (tabela zmiennych).

Otworz VAT podwdjnym kliknieciem
a znajdziesz sie w oknie ,Monitoring
and Modifying Variable”.
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Tabela zmiennych jest poczatkowo pusta. Wprowadz nazwy symboli lub
adresy dla przyktadu ,Getting Started” zgodnie z rysunkiem. Pozostate dane
zostang uzupetnione, jesli zatwierdzisz wprowadzony element klawiszem

Return.

Zmien format statusu wszystkich wartosci obrotow na format DEC. Kliknij na
odpowiednig kratke (strzatka myszy na kolumnie ,Monitor Format”) i wybierz

format DEC.
BiVar - VAT_1 =]
Table Edit Inset PLC “arable “iew Options ‘window Help
| &617]

1| [ ey _1" BOOL
2_ [ "Ry 2" BOOL
ER AL "lireen_Light"* BLUUL
&
5| Mw 2 PE_fctual Speed” DEC
15 | DE1.DEW B "Petrol" Preset_Speed DEC
7_ o a1 "PE_Preset_Speed Reached" BOOL
8
3] Mw 4 "DE_Actual_Speed” DEC
110 DBZDEW B "Diesel" Preset_Speed DEC
m) o 55 "DE_Preset_Speed Reached" BOOL
2]

Pracs F1 Far halp D |Dffee bz 2 B3

| H| Zapisz swojg tabele zmiennych.

Zataczenie tabeli zmiennych w tryb Online

RUNP  —
RUN =

STOP e
MAES ——

Kliknij przycisk ON w oknie "Monitoring
% | and Modifying Variables".Zostanie

stworzone potaczenie Online. W listwie

statusowej pojawi sie napis ONLINE.

Ustaw kluczyk w pozyciji RUN-P (o ile nie
jest juz tak ustawiony).
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Obserwacja zmiennych

Kliknij na Monitor Variable. W
listwie statusu widoczny jest tryb
pracy CPU.

Wiacz Przycisk 1 i 2 na wejsciach
sterownika i obserwuj wynik w
tabeli zmiennych.

W tabeli zmiennych status wejs¢
zmienia sie z ,false” na ,true”.

Modyfikacja zmiennych

Wprowadz wartos¢ 1500 dla MW2 w kolumnie Modify Value, i dla MW4
wprowadz 1300.

[EA[Var VAT 1] [_ (O[]
Tsble Edit [nset PLC Vaishle iew Qptions Window Help

| Df2(a] S & [Ee] o] %] =T el sl v @] o]
(=20 2fF et &= |

$A[VAT_1 - @hetting Started\SIMATIC 300 StalionSCPUS14[1)\57 Piogram 0] - O] %]
A Addiess Symbol Display format| Status value [ Modify value]

i 1 o1 ey 1" BO0L e

2| oz ey 2 BO0L [ e

3] U 40 VGreen Light T 0t

4 1

5] ww ZPE_Aowal Sposd” DEC e 150

6| DB1DBW & "Petral"Presel Speed DEC 1500

7 ‘o 51 'PE_Preset_Speed_Reached’ ROOL 1 hue

8

91 IMw 4 DE_ActualSpesd’ DEC 0 @ i
10| DBZDEW B 'Diesel’ Fresst Speed DEC -~ 1w

| 0 BRDF_Piesel_Snesr_Reached’ RO Tl

12
MBI~ 2 {dvecily] @ [RUN [Abe 2 5.2 %

|It‘l'illll Przenie$ wprowadzone wartosci
do sterownika.
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Po przestaniu danych do CPU, mozna zaobserwowaé wynik poréwnania.

AL Var - VAT_1 = E3
able Edt et PLC Vgiable ew Opions Window Help

2| DIzl & &lmel || 7] =l kel Sfar w| sl
T P P =N e

A Addiess Symbal Display formal| Status value | Modiy valud
T o ey 1" Ba0L e
|02 ey 2 BOOL Irue
Ual T reen Light” BULL e
Mz “PE_Actual_Spoed” DEC 1500
DB1.DEW B "Petrol Presel_Speed DEC 1500
0 &1 "PE_Preset_Speed_Reached” ROOL tru=
Mw 4 DE_AclualSpeed” DEC oo 1300
DE2DEW & "Digsel” Preset_Speed DEC 1200
&R "TIF_Preset_Speed_Reached” RONI e
MP) = 2 [dvactly) 4 [RUN Ao < B2

Czesto ze wzgledu na ograniczenia ekranu bardzo obszerna tabela zmiennych
nie moze by¢ pokazana w catosci.

Jesli posiadasz duzg tabele zmiennych, zalecamy tworzenie za pomocg STEP 7
kilku tabel zmiennych do programu S7. Tabele te mozna dopasowac doktadnie do
twoich potrzeb testowych.

Analogicznie do blokéw tabelom zmiennych mozna przyporzgdkowywac
indywidualne nazwy symboliczne (np. zamiast VAT1 nazwe OB1_siec1).
Przyporzadkowanie nazw odbywa sie w tabeli symboli.

Dalsze informacje znajduja sie w Help >

Contents w rozdziatach "Debugging" i
"Testing with the Variable Table."
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7.5 Wywotanie bufora diagnostycznego

W przypadku gdy podczas pracy programu CPU przejdzie w STOP, lub po
zatadowaniu programu nie da sie przetaczy¢ na RUN, mozna ustali¢
przyczyne takiego zachowania na podstawie informacji znajdujacych sie w
buforze diagnostycznym.

Warunkiem jest istniejace potgczenie Online oraz CPU w trybie STOP.

Ustaw przetacznik trybu pracy na

RUN f@ ,STOP".
STOP

I MUNE\S LTS o cem Punktem wyijscia jest znéw
arc 3 - = & & SIMATIC Manager z otwartym
' projektem ,Getting Started Offline”.

Zaznacz folder Blocks.

PLL BEER Jesli twdj projekt zawiera kilka
= CPU, ustal wpierw, ktére CPU

Dionos iavars ustawione sg na STOP.

Disgnnsing Hairdwaie - Quick View W polu dialogowym ”Diagnosing
Bof  [Feti Stated SIMATIC 300 SWrhCPUS A1 7 Pogasi] Hardware” znajduje si¢ lista

o e ) WSZystkich znalezionych CPU.
AT, | Zaznaczony jest CPU w stanie

STOP.

masmonne. | | W Projekcie ,Getting Started”
e zdefiniowane jest tylko jednym

_ Updwe | CPU.
[ Display quck visw when dagnatng haidwars
Close b | | Kliknij na Module Information,
aby zobaczy¢ bufor diagnostyczny
tego CPU.

Jesli jest podtaczone tylko jedno
CPU, mozesz bezposrednio
zbada¢ stan modutéw sterownika
wykorzystujac funkcje w menu
PLC > Module Information.
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W oknie ,Module Information” mozesz znalez¢ informacje o cechach i
parametrach twojego CPU. Aby sprawdzi¢ przyczyne trybu pracy STOP

wybierz zaktadke Diagnostic Buffer.
w]Mndule Information - CPU314 OMNLINE
Path:  [Gelting Started\SIMATIC 200 Station\CPUS14[1\37P  CPU operating mode: ~ STOP
Ciall

] | Stacks
Scan Cycle Time

Timne System
Gergral

Communication
Memory I

=10l x|

epm  10/12/38

3 1232357 STOP caused by stop switch being activated
4 12:32:30:830 pm 1012/98  Mode trangition from STARTUR to RUN
5 1232:30:290 pm 10412/98  Request for manual complete restart
b 12-32-30:890 pm 10/12/98  Mode tranzition from STOP to STARTLP
7 123213470 pm 10412238 STOP caused by stop switch being activated
8 12:32:18:090 pm 10/12/98  Mode hangition from STARTUP to RUN
Details on event: 1of 20 EventID. 16H 4303

STOP caused by stop switch being activated

Previous operating mode: STOP [internal]
Flequested cparating made: STOF [itemal]
Incoming event

Savefs..

Satlings. .

]

Help on Exent I

o |

Update

Pint..

Klawisz ,Open Block”
jest nieaktywny,

poniewaz przyczyna,
trybu STOP nie byt
btad programu

Ostatnie wydarzenie (nr 1) znajduje sie na najwyzszej pozycji. Pokazana jest
przyczyna wystapienia STOP. Zamknij wszystkie okna, az do poziomu

Managera SIMATIC.

Jesli przyczyng STOP jest btad prog
pole Open .

ramu, zaznacz wynik wydarzenia i kliknij na

Blok zostanie otwarty w znanym juz oknie edytora programu LAD/STL/FBD, a

btedna sie¢ zostanie zaznaczona.

Ten rozdziat konczy przedstawianie tworzenia projektu ,Getting Started” od
momentu jego zatozenia do testowania pracujacego sterownika. W nastepnych
rozdziatach pogtebisz swojg wiedze wykonujac przedstawione éwiczenia.

Dalsze informacje znajduja sie w Help >
Contents w rozdziale "Calling the Module
Information.”
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8.1

Programowanie funkcji FC

Zatozenie i otwarcie funkciji

Funkcja, podobnie jak blok funkcyjny, przyporzadkowany jest blokowi
organizacyjnemu. Zatem by funkcja mogta by¢ wykonana, nalezy ja wywotac
bezposrednio w OB, lub tez w innym bloku przyporzgdkowanym temu OB.
Funkcja w przeciwienstwie do bloku funkcyjnego, nie ma przyporzgdkowanego
bloku danych.

Podobnie jak w FB, funkcja moze mie¢ takze zadeklarowane parametry,
jednakze nie posiada danych statycznych.

Analogicznie jak inne bloki, funkcje programuje si¢ w edytorze LAD/STL/FBD.

Znamy juz programowanie w postaci LAD, FBD lub STL (rozdz. 4) czy tez
programowanie symboliczne (rozdz. 3).

Jesli zgodnie z rozdziatami 1-7 zostat
stworzony projekt ,Getting Started”,
nalezy go otworzy¢.

Jesli nie, prosze zatozy¢ nowy projekt
wykorzystujac w SIMATIC Manager
funkcje File > "New Project" Wizard.
Postepujac zgodnie ze wskazéwkami w
ZOK0T 05 STEF.. rozdziale 2.1 nalezy zmieni¢ nazwe na
Zowoi_oe_sTER..  ,Getting Started Function”.

K I Dalej bedziemy postugiwac sie
projektem ,Getting Started”. Mozna

jednak powtarzac kroki na projekcie
stworzonym przez siebie.

i |
ZOw01_2_STEF.. [
ZOR01_3_STER.. [
ZOe01_04_STEPR.. [
(
(

Otworz folder Blocks.

Kliknij prawym klawiszem myszy na
prawej czesci okna.
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Wprowadz funkcje uzywajac menu

€ Insert New Object ) kontekstu

EiSas =R iz W oknie "Properties — Function”
Eznala\[if:alm‘]i Genela\-|2] Cals | Aibutes | Wybierz nazwe bloku FC1 . oraz ]ezyk
L — w jakim chcesz tworzy¢ program.
Syrmbol
Busloiil | . Potwierdz ustawienia za pomoca
S L klawisza OK.
of project [E*Siemens Stepr S TpraiGettin 1

Code Intetface
et e 12.04.2000 13:02:18
e et 12.04.2000 130218 12.04.2000 130218
Comment: | ;‘
|
Abbrechen Hile

Funkcja FC1 pojawi sie w prawej
czesci okna.

By otworzy¢ funkcje kliknij dwukrotnie
na FC1.

Wewnatrz funkcji, w przeciwienstwie do bloku funkcyjnego, nie mozna definiowaé
parametrow statycznych.

Dane statyczne definiowane w bloku funkcyjnym zachowujg swoja wartosc.
Odpowiednikami danych statycznych bedg takze stowa merkeréw (znacznikéw
MW) np. dla wartosci granicznej obrotéw. (patrz rozdz. 5).

Podczas programowania funkcji mozna wykorzystywac nazwy symboliczne.

Dalsze informacje znajduja sie w Help > Contents
w rozdziale "Working Out the Automation
Concept," "Basics of Designing a Program
Structure," i "Blocks in the User Program."
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8.2 Programowanie funkcji

W naszym przyktadzie zaprogramujemy funkcje czasowa. Funkcja bedzie
dziataé w ten sposob, iz po zataczeniu silnika (rozdz. 5) zatgczony zostanie
wentylator, ktéry po wytgczeniu silnika bedzie pracowac jeszcze przez cztery
sekundy. (Opdznienie wytgczenia).

Zgodnie z powyzszym nalezy zadeklarowa¢ parametry wejsciowe i wyjsciowe
funkcji.

Otworzmy edytor programu LAD/STL/FBD. Deklaracje parametréw nalezy
przeprowadzi¢ podobnie, jak przy parametryzacji bloku funkcyjnego (rozdz. 5).

Wprowadz ponizsze parametry:

Contents OF: ‘Erviranment'lnterfacet|N'

[ Intstace [Mama Data Type |Comrmant

+ ‘= |Engine_0On Boal Sigaal for switching on the engire

< UUT ‘@ Timer_lunction |Timer Tirrerfunction used for the switch-off dels
ok (N_OUT o
I3 TFHMP

Contents OF ‘Environmentt/nteface 00T

(3 Interface [Mame Data Type [Somment
-4 @ [Fan_on Boal Signal for switching on the fan
# =!

Tk IN_OUT

2 TEMP

Programowanie funkcji czasowej w LAD

; Zaznacz linie wprowadzania
@A Timers elementow LAD.

\ i Znajdz w katalogu funkciji czton
] S_OFFDT  czasowy S_OFFDT, i wprowadz go
do sieci.

Wprowadz na wejscie S styk

= T o 7.7 normalnie rozwarty.
D T D
El=, . .

Wprowadz cewke na wyjscie Q.

PIP=TV

. =R BCDE. ..
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Zaznacz znaki zapytania i wprowadzZ w to miejsce nazwe parametru z tabeli
deklaracyjnej (automatycznie zostanie poprzedzona znakiem # ).

Na wejscie TV wprowadz warto$¢ czasu opdznienia. Postaé wprowadzana
S5T#4s oznacza iz wprowadzana jest warto$¢ stata w formacie S5TIME#
(S5T#) o wielkosci 4 sekund.

Zapamietaj stworzong funkcje i zamknij okno.

#Timer Function

#Engine On

I
1T o

SETHAS TV

..—R

S_OFFDT

s

BI

ECD

#Fan On
{1 |

L 1

Parametr wejsciowy ,Engine_ON” powoduje
uruchomienie #Timer_Function. Pézniej trzeba
bedzie stworzona funkcje FC wywotaé
dwukrotnie w bloku OB1, raz dla silnika
benzynowego, drugi raz dla silnika Diesla.
Podczas wywotania trzeba bedzie okreslié
parametry, ktére potem mozna oznaczy¢
symbolem w tabeli symboliczne;.

Programowanie funkcji czasowej w STL

A #Engine On

L SOTHAS

SF #Timer Function
#Timer Function

I e

#Fan On
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W przypadku programowania w
postaci STL ustaw kursor na polu
wprowadzania programu i wpisz obok
przedstawione instrukcje.

Zapisz wprowadzong funkcje i
zamknij okno edytora.



Programowanie funkcji czasowej w FBD

W przypadku programowania w FBD ustaw kursor na polu wprowadzania
funkgciji i stwérz odpowiednig funkcje czasowa.

Zapisz wprowadzong funkcje i zamknij okno edytora.

#Timer Function

S_OFFDT
#Engine On =3 EIp=...
SETHAS — TV BCD ... #Fan On
. —R o

By stworzona funkcja mogta byé prawidtowo przetwarzana, nalezy ja wywota¢ w
odpowiednio przyporzadkowanym bloku nadrzednym (np. w OB1).

Dalsze informacje znajduja sie w Help
>Contents w rozdziale "Calling Reference
Helps", "The STL, FBD, or LAD Language
Description”, i "Timer Instructions."
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8.3

Wywotanie funkcji w OB1

Wywotanie funkcji FC1 w bloku OB1 wykonuje sie tak samo jak we wczesniegj
stworzonym bloku funkcyjnym. Nalezy przy wywotywaniu funkcji okreslic
wszystkie jej parametry.

Jesli ktérys z operandbéw przypisywanych do parametréw nie posiada nazwy
symbolicznej, nalezy uzupetni¢ to uzywajac tabeli symboliczne;.

Operant jest fragmentem instrukcji w STEP 7, ktory
mowi z czym procesor powinien co$ zrobié. Moze on
byé w postaci absolutnej lub symboliczne;.

Otwarty jest aktualnie projekt ,Getting
Started”, lub tez projekt stworzony
samodzielnie.

Dojdz do folderu Blocks i otwérz blok
OB1.

Otwiera sie okno edytora
LAD/STL/FBD.
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Programowanie wywotania w LAD

Fan

Znajdujemy sie w postaci LAD.
Whprowadz nowa sie€ (6). Znajdz w
katalogu elementéw programowych
folder FC Blocks, a w nim FC1, i
wprowadz do programu.

Wstaw styk normalnie rozwarty na
wejscie ,Engine_On”.

Uzywajac View >Display >Symbolic
Representation, mozemy wybra¢ miedzy
symbolicznym i absolutnym sposobem
adresowania.

Kliknij na znaki zapytania i wprowadz dalsze nazwy symboliczne.

"PE Follow on"—

EN

Engine On

Timer Function

PRan

ENO

Fan On—"pE Fan oOn"

W sieci 7 zaprogramuj wywotanie FC1 dla silnika Diesla. Sposob
postepowania jest analogiczny, jak w ww. przypadku (w liscie symbolicznej
powinny znajdowac sie wczesniej przygotowane symbole dla potrzebnych

operandow).

"DE_Follow On" —

EN

Enginc On

Timer Function

MEan ™

ENC

Fan_Cn—"DE Fan On"

=1

Zapisz blok i zamknij okno edytora.

Uaktywnij polecenie menu View >Display > Symbol
Information by w kazdej z sieci pojawity si¢ opisy symboli.

By zwiekszy¢ ilos¢ sieci prezentowanych na ekranie wylacz
View > Display > Comment oraz, w razie potrzeby View >

Display > Symbol Information.

Uzywajac polecenia menu View > Zoom Factor, mozna
zmieni¢ rozmiary wy$wietlanych instrukcji programowych.
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Programowanie wywotania w STL

Hetwork 6 : Controlling the Fan for the Petrol Ensine W przypadku programowania

CALL "Fan" w STL, wejdz w obszar
Engine_On :="PE_On" R Z
Timer Function:="PE_Follow On" _programowanla | WprOWadZ
Fan_on :="PE_Fan_on" InStI‘Uije pOdane ObOk

Hetwork 7: Controlling the Fan for the Diesel Engine ZapISZ Wpl’OW&dZOﬂy program
A on i zamknij okno edytora.

Engine_On :="DE_on"
Tiwer Function:="DE Follow On'"
Fan_On :="DE_Fan_On"

Programowanie wywotania w FBD

W przypadku programowania w FBD wejdZz w obszar wprowadzania diagramu
funkciji i operujac w katalogu funkcji wprowadz ponizej przedstawione
elementy.

Zapisz wprowadzony program i zamknij okno edytora.

"Fan"
..=—EN
"PE_On" —Engine_On Fan On="2E Pan On"
"PE_Follow On" —Timer Function ENO -
"Fan"
.. =—EN
"DE_On" = Engine_On Fan Cni—"pE Fan On"
"DE_Follow On" — Timer_ Function ENO[—

W naszym przyktadzie zastosowali$my wywotanie bezwarunkowe funkcji, tzn.
kazdorazowo funkcja bedzie realizowana bez wzgledu na wynik wczes$niejszych
operacji logicznych.

Mozna jednak w razie potrzeby realizacje FC lub FB uzalezni¢ od pewnych

warunkow np. od jakiego$ wejscia. By zrealizowa¢ wywotanie warunkowe nalezy
ten warunek wprowadzi¢ na wejscie EN.

Dalsze informacje znajdujg sie w Help >
Contents w rozdziatach "Calling Reference
Helps," "The LAD, FBD, or STL Language
Description," lub"Program Control Instructions."
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Programowanie globalnego bloku danych

Zaktadanie i otwieranie globalnego bloku danych

Jesli ilos¢ wewnetrznych znacznikow (merkeréw) w CPU (komoérki pamieci) nie
jest wystarczajgca do zapamietania wszystkich danych, pewne wybrane dane
mogg zostac zarchiwizowane w globalnym bloku danych.

Dane globalnego bloku danych sa dostepne z kazdego bloku programowego.
Lokalny blok danych jest przyporzadkowany okreslonemu blokowi
funkcyjnemu, dane dostepne sg tylko w tym bloku (por. rozdz. 5.5).

Zapoznates$ sie juz z programowaniem w LAD, STL i FBD (por. rozdz. 4 i 5) jak
i programowaniem z wykorzystaniem symboli (por. rozdz. 3).

Jesli przeprowadzite$ przyktadowy
projekt ,Getting Started” z rozdziatu
1-7, otwédrz go teraz.

Jesli nie, zat6z nowy projekt w
SIMATIC Manager za pomocg File >
»New Project” Wizard . Analogicznie
do rozdziatu 2.1 nazwij projekt

Z01_ 05 STEF

Z0H1_D3_STEP..
ZDt01_04_STEF... ,aetting Started Global-DB”.
Z0H1_05_STEP..

ZDH1_DE_STEF... . . -
i Punktem wyjscia w dalszej czesci

bedzie projekt ,,Getting Started”.
Mozesz jednakze wykonac¢ kazdy
krok rowniez w nowo zatozonym
projekcie.

Przejdz do folderu Blocks i otwoérz
go.

Kliknij prawym przyciskiem myszy na
prawe pole okna.
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Shaied data Black,
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Dodaj Data Block z Menu
kontekstu.

W polu dialogowym ,,Properties -
Data Block” potwierdZz wszystkie
ustawienia klawiszem OK.

Dla uzyskania dalszych informacji
uzyj Help.

Blok danych DB3 dodany zostanie
do katalogu Blocks.

Podwojnym kliknieciem otwérz

' DB3.

Wskazowka: w rozdziale 5.5,
utworzony jest lokalny blok danych
aktywujac opcje "Data block
referencing a function block." Za
pomoca "Data block" tworzony jest
za to globalny blok danych .




Programowanie zmiennych w bloku danych

W kolumnie Name
-PE_Actual_Speed”.

By ustali¢ typ wybierz prawym
przyciskiem myszy z menu
kontekstu Elementary Types
> INT.

Zdefiniowano przyktadowo trzy dane globalne w DB3. Uzupetnij odpowiednie
dane w tabeli deklaracyjnej zmiennych.

+0.0| [ps_vir
|

INT

Rddress |Hane Type Initial vali|Comment
0. STRUCT
0 Temporary placeholder wariable

Zmienne stanu obrotéw w bloku danych
-PE_Actual_Speed” i ,DE_Actual_Speed”
traktowane sa tak samo jak stowa znacznikow
(merkerow) MW2 ,PE_Actual_Speed” i MW4
-,DE_Actual_Speed”. Pokazemy to w nastepnym
rozdziale.

E | Zapisz globalny blok danych.
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Przyporzadkowanie symboli

Blokowi danych takze mozesz
przyporzadkowaé nazwe
symboliczna.

Symbol Table Otworz Symbol Table i wprowadz

dla bloku danych DB3 symbol
»o_Data”.

Options

Jesli w rozdziale 4 kopiowates$ tabele
symboli z przyktadowego projektu
(zEn01_02_STEP7__STL_1-10,
zEn01_06_STEP7__LAD_1-10 lub
zEn01_04_STEP7__FBD_1-10) do
swojego projektu ,Getting Started”, nie
musisz teraz wprowadza¢ nowych
symboli.

Symbol ' Address |Data Type Comment

S _Data DB 3 DB 3 Shared data block

Zapisz tabele symboli i zamknij
E okno ,,Symbol Editor”.
Zamknij tez tabele deklaracji

zmiennych globalnego bloku
danych.

Globalny DB w tabeli deklaracji zmiennych:
Uzywajac View > Data View mozesz zmieniaé aktualne warto$ci danych typu INT
w tabeli globalnego bloku danych (por. rozdz. 5.5).

Globalny DB w tabeli symboli:

W przeciwienstwie do lokalnego bloku danych typ danych globalnego DB w tabeli
symboli jest zawsze adresem absolutnym. W naszym przykfadzie typ danych to
,DB3”. Dla lokalnego bloku danych na state podany jest jako typ danych
przynalezny FB.

Wiecej informaciji uzyskasz pod Help > Contents
~Programming Blocks” i ,Creating Data Blocks”.
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10

10.1

Programowanie wielokrotnego lokalnego bloku
danych

Zaktadanie i otwieranie nadrzednego bloku funkcyjnego

W rozdziale 5 zostat zaprogramowany blok funkcyjny FB1 ,Engine”, ktéry
sterowat dziataniem silnika. Przy wywotywaniu tego bloku w OB1
wykorzystywane byly bloki danych ,Petrol” (DB1) i ,Diesel” (DB2). Bloki
danych zawieraty parametry pracy danego silnika.

Co zrobié, jesli w swoim programie potrzebujemy stworzy¢ uktady sterowania
wiekszej ilosci silnikow.
Zgodnie z wcze$niej przedstawionym tokiem postepowania nalezatoby

kazdorazowo wywotac blok FB1 i stworzyé do niego kolejne lokalne bloki
danych. Bytyby to np. DB3 i DB4.

Mozna unikng¢ tworzenia wiekszej ilosci takich blokéw danych stosujac
wielokrotny lokalny blok danych. Zat6zmy zatem nowy blok funkcyjny (w
naszym przyktadzie FB10), i wywotajmy w nim niezmieniony blok FB1 jako
sokal instanz”. Kazdorazowo wywotanie FB1 powoduje dodanie danych w
DB10 — lokalnym bloku danych przyporzadkowanym FB10. Wszystkie
wywotane FB bedg pracowaé na jednym bloku (tutaj DB10).

W DB10 zintegrowane zostana bloki DB1 i DB2.
Niezbednym do tego jest zadeklarowanie FB1 w
zmiennych statycznych bloku FB10.

OB1 FB10

CALL FB1 (for petrol engine)
CALL FB10, DB10 CALL FB1 (for diesel engine)

FB1
:> L "Engine"
% o DB10

= "Petrol engine" data
"Diesel engine" data

T

FB1

=
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Znamy juz programowanie w LAD, STL oraz FBD, a takze reprezentacje
symboliczna.

g Projects

DHT_OT_STEP..
ZD01_02_STEP...
ZDt1_03_STEP..
ZOt01_04_STEP..
ZOt1_D5_STEP...
ZDt1_DE_STEF...

: B STEP

Gerrad-Pat 1 |

TS

Hame

‘Symbal Cmment: |

Cimsledin Larguage. [STL =

Project Peth [

of projert [ Siemens S lepra fpranaetin 1

Code kel e

Dl crealed. TRASN0 UBABZT

Last modded. TEAISA2000 U8 ABZT TBAS/2000 DE482T

Comment: |

1]

T e |

[Open | Jesli zgodnie z rozdziatami 1-7 zostat

stworzony projekt ,Getting Started”,
nalezy go otworzyé.

Jesli nie, prosze otworzy¢ w
Managerze SIMATIC jeden z
projektéw:
zEn01_06_STEP7__LAD_1-9dla
LAD,
zEn01_02_STEP7__STL_1-9dla STL
zEn01_04_STEP7__FBD_1-9 dla
FBD.

Otworz folder Blocks.

Kliknij na prawej czesci okna prawym
klawiszem myszy i za pomoca menu
kontekstu wprowadz blok funkcyjny.

Zmien nazwe bloku na FB10 i ustal
dogodng posta¢ programowania.

Jesli jest to potrzebne, aktywuj opcje
Multiple instance, i zatwierdz
dokonane ustawienia przyciskiem OK.

Blok FB10 pojawi sie w folderze
Blocks. Otworz go podwdjnie klikajac.

Wielokrotne bloki danych moga byé tworzone w potaczeniu z dowolnymi blokami
funkcyjnymi (np. z przeznaczeniem do sterowania zaworami). Jesli chcemy
pracowac wykorzystujgc bloki wielokrotne, nalezy uwaza¢ na to, by byto to
mozliwe zaréwno dla bloku nadrzednego, jak i podrzednego.

Dalsze informacje znajduja sie w Help >
Contents w rozdziatach "Programming
Blocks" i "Creating Blocks and Libraries."
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10.2 Programowanie FB10

By wykorzystywa¢ blok FB1 jako wielokrotny nalezy dla kazdego jego
wywotania stworzyé w czesci deklaracyjnej FB10 zmienne statyczne
(kazdorazowo opisane inng nazwa). Jako typ danych nalezy wybra¢ FB1.

Wypetnienie tabeli deklaraciji

Otwarte jest okno edytora programowego. Zadeklaruj do wywotania FB1
nastepujace zmienne.

| Contents OF: ‘Environment\lnterface 0T
i Interface [Mame ‘Data Type|Address [Initial Yalug[Comment

‘2 Preset_Speed_Reached |Bool 0.0 FALSE Baoth engines have reached the preset speed
+ a
T

o STAT
o TEMP

| Contents OF: ‘Environment\Interface S TAT'

) Inteiface [rame Data Type [Address [Initial Yalue[Comment
o N @- Petrol_Engine |Engine 2.0 Firstlocal instance of FB1 "Enging"
+- 0k OUT G Diesel_Engine |Engine  10.0 Second local instance of FB1 "Enging”

+

@

| Contents OF: ‘Environment\Interface\TEMP'

5

F nterface [ [Name Data Type[Address[Comment
0 N ‘2 FPE_Preset_Speed_Reached |Baol 0.0 Freset speed reached (petrol engine)
+-0 OUT ‘= DE_Preset_Speed_Reached |Bool 0.1 Freset speed reached (diesel engine)
O IN_OUT 0

@

Zadeklarowane bloki wielokrotne znajdg
sie w efekcie naszych dziatan w katalogu
elementéw programowych pod nazwg
"Multiple Instances."
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Programowanie FB10 w LAD

Wprowadz w sieci 1 wywotanie
wielokrotnego bloku
sPetrol_Engine”.

Uzupetnij wejscia odpowiednimi stykami oraz nadaj stykom adresy np. w
postaci symboliczne;.

#Petrol Engine
EN ENO

"Bwitch On_PE" Engine Onp"pg oOn'"

i} Switch On

Preset_Speed Reac| 4PE Preset Speed R
"Switch Off PE" hed

| = Switch Off

Feached

Teraz warto$¢ biezaca predkosci
obrotowej nie bedzie czytana jak
dotychczas z stowa znacznikéw (jak w
rozdz. 5.6), ale ze stworzonego bloku
Actual Speed danych (patrz rozdz. 9.1). Ogdlnie
adresem bedzie "Data_Block"np.:
"S_Data".PE_Actual_Speed.

"PE_Failure"

: I Failure

"3 Data".PE Actual
_Speed

|

Wprowadz nowg sieé i postepujac zgodnie z poprzednim przyktadem dotéz
wywotanie bloku dla silnika Diesla.

#Diesel Engine

N LHO
"Switch On DEM Engine Oni-"DE On"

| | Switch On

Preset_Speed_Reac| #$DE_Preset_Speed_R

"Fwitch Off DE" hed Feached

|} Switch of:
"DE_Failure"

Il rallure

"5_bata”.DE_actual
Speed —|actual Speed
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Whprowadz kolejna sie€ i zaprogramuj potaczenie szeregowe odpowiednio je
adresujac. Nastepnie zapisz program i wyjdz z bloku programowego.

#PE_Preset Sp=ed R #DE Preset Speed R #Freset Speed Reac
eached eached hed
[} |} {} || Zmienne lokalne
! ("PE_Setpoint_Reached" i

"DE_Setpoint_Reached") przypisane
zostang do parametru wyjsciowego
"Setpoint_Reached," ktory bedzie
mogt by¢é wykorzystany w OB1.

Programowanie FB10 w STL

CALL #Petrol Engine

Switch On 1="Zwitch On PE" .
switch Off :="Switch_Off_PE" W przypadku programowania w
Failure (="PE_Failure™ :
Actual Speed :="S_Bata".PE_Actual_SpEEd pOStaCI STL WStaW noWy Segment’
Engine_On i="FPE_on" ustaw kursor na polu wprowadzania
Preset Zpeed Reached:=#PE Preset 3peed Reached programu | WplSZ Obok

’
CALL #Diesel Engine przedstawione instrukcje.
Switch On :="Switch On DE™ i i
Switch OFf :="Switch OFf_DE" Zap|sz Wprowadzony program i
Failure :="DE_Failure" .
Actual Speed :="5 Data".DE_Actusl Speed Zamknl] bIOk
Engine On :="DE On"

PrEsEt_SpEEd_REachEd:=#DE:PIESEt_SpEEd_REachEd

#PE_Preset_Speed Reached
#DE_Preset_Speed Reached
#Preset_Speed Reached

LT
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Programowanie FB10 w LAD

W przypadku programowania w FBD, ustaw kursor na polu wprowadzania
programu w nowej sieci i wprowadz z katalogu odpowiedni diagram
funkcyjny.

Zabezpiecz wprowadzony program i zamknij obrabiany blok.

#Petrol Engine

«. —EN

"Switch_On PE" ——{Switch_On

"Switech Off PE" —Suitch Off Engine Onj"p® om"
"PE Failure™ —Failure Preset_Speed Reac| 4PE Preset Speed R
hed l—eached

"5 Data".PE_Actual
Speed —Actual Speed ENO

#Diesel Engane
.. —EN
"Suiteh Om_DE" —Switch On
"Switch Off DE" —{Switch Off Engine Onp="0E on"
"DE Failure" —Failure Preset Speed Reac| BDE Preset Speed R
hed —eached
"% _Data”.DE_Actual
Speed —ictual Speed ENO =
&
#PE_Presst Speed R
eached — fiPreset_Speed Reac

hed
#DE_Preset_Speed R =
eached —

By byto mozliwe wywotanie wielokrotne bloku FB1, blok nadrzedny FB10 musi
by¢ sam wywotany np. w OB1.

Bloki wielokrotne mozna programowac z przeznaczeniem dla FB. Nie mozna
zaprojektowac bloku wielokrotnego dla funkciji.

Dalsze informacje znajdujg sie w Help >
Contents w rozdziale "Programming Blocks,"
"Creating Logic Blocks," i "Multiple Instances in
the Variable Declaration Table."
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10.3 Tworzenie DB10 i wstawianie aktualnych wartosci

Nowotworzony blok DB10 bedzie zastepowac bloki DB1 i DB2. W nim zostang
zapamietane dane dla silnika benzynowego i Diesla, ktére potem bedg
wykorzystywane przy wywotaniu bloku FB10 w bloku OB1. (patrz tez
wywotanie FB1 w OB1.)

Uzupetnij nasz projekt
wprowadzajac do foldera Blocks
blok DB10 (wykorzystujac menu
kontekstu uruchamiane prawym
klawiszem myszy).

Zmien w tym celu numer bloku na
DB10, oraz zatwierdz ustawienia
klawiszem OK.

Prepesies: Deta Shoos 5 Podwdjnie kliknij na blok DB 10.

Genersi- Pant 1 | Genessl - Pyt

Hame and type
‘Symbokic Hame:
Symbed Cormmert: | . URT
e D W nastepnym oknie wcisnij
Poct pa I przycisk YES. Blok DB 10 zostaje
S ko [ERSmans a7 vS Tpeaiaatin T t it
Code Inledace 0 Wa y'
Diate coested UI0/2002 D4 3250
Lt moschfiedt 09/10v2002 043250 09/10/2002 D4:3250
Cgmment ‘ = |
|
Cancal Hip |

Open Data Block

By default, instance data blocks are opened with "Parameter assignment
for data blocks" as of STEP 7 W5.2 [see Help),

There is no functional difference for this DB to the editor in
LADASTLAFRD.

The DB could be opened with the DB editar in LAD/STLAFBD [as in
VE.1).

Da you want to open the DB wih 'Parameter assignment for data
blocks"?

¥ Always display this message for Open Instance DB

No Help |

Posta¢ wyswietlania danych umozliwia
wyswietlenie szczegotowych wartosci, takze
takich, ktére wynikaja z wywotania bloku FB1.
Posta¢ deklaracyjna prezentuje dane w
formacie zadeklarowanych parametrow w
FB10.
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Zmien aktualng wartosc¢ dla silnika Diesla na 1300, zapisz zmiany i zamknij
blok.

|

[
[
B
e

i

W postaci deklaracyjnej tabeli widoczne sg tylko ogoélne dane dla poszczeg6inych
silnikow.

Zmienne wewnetrzne bloku FB1 posiadaja swoje nazwy symboliczne np.
,Eingine_On”. Dostep do nich jest mozliwy dzieki podaniu petnej nazwy np.:
"Petrol_Engine.Switch_On."

Dalsze informacje znajdujg sie w
Help > Contents w rozdziale
"Programming Blocks" i "Creating

Data Blocks."
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10.4 Wywotanie FB10 w OB1

W naszym przyktadzie blok FB10 zostanie wywotany w bloku OB1. Zasada
budowy i funkcjonowania tego wywotania jest identyczna, jak przy zrobionym
juz wywotaniu bloku FB1 (patrz rozdz. 5.6). W rozdziale 5.6 do
zaprogramowania uzyli§my wywotan w sieciach 4 i 5.

Otworz blok OB1 w projekcie, w
ktérym wtasnie zaprogramowates
blok FB10.

=

Jesli w rozdziale 4 skopiowate$
przyktadowg tabele symboli do Twojego
projektu, nie trzeba ich teraz ponownie
definiowac.

Definicja nazw symbolicznych

Otwarte jest okno edytora programu. Otworz tabele symboli uzywajac w menu
Options > Symbol Table i wprowadz oznaczenia symboliczne dla blokéw
FB10i DB10.

Zamknij tabele i okno symboli.

Symbaol | Address |Data Type| Comment
Engines FE 10 FB 10 |Example of multiple instances

Engine_Data DE 10 FB 10 |Instance data block for FB10 10

Stworzenie wywotania bloku

Wprowadz na korcu bloku nowg siec,
i uzupetnij go o wywotanie bloku
FB10 (,Engines”).

{F FB10  Engines
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Uzupetnij wolne pola wywotanego bloku odpowiednimi nazwami
symbolicznymi.

Usun w sieci 4 i 5 dotychczasowe wywotania bloku FB1. Teraz blok ten
wywotywany jest tylko w FB10.

Zapamietaj program i zamknij blok.

"Engine Data”

"Enginse"
EN ENO;

Preset Spezd Reac| "3 Date”,Preset Sp

hed =ead Peached

Sygnat wyj$ciowy bloku:
,Preset_Speed_Reached” przekazywany
jest do globalnego bloku danych.

Wywotanie w STL

Jesli postugujemy sie postacia STL, w nowo stworzonej sieci wejdz na pole
wprowadzania programu, i wpisz ponizej podane instrukcje. Uzyj w tym celu
element katalogu FB Blocks>FB10 Engines.

Usun w sieci 4 i 5 dotychczasowe wywotania bloku FB1. Teraz blok ten
wywotywany jest tylko w FB10.

Zapamiegtaj program i zamknij blok.

CALL ,Engines”, ,Engine Data”
Preset Speed Reached:="S Data”.Preset Speed Reached
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Wywotanie w FBD

Jesli postugujemy sig postacia FBD, w nowo stworzonej sieci wejdz na pole
wprowadzania programu i wpisz ponizej podane instrukcje. Uzyj w tym celu
element katalogu FB Blocks>FB10 Engines.

Usun w sieci 4 i 5 dotychczasowe wywotania bloku FB1. Teraz blok ten
wywotywany jest tylko w FB10.

Zapamietaj program i zamknij blok.

"Engine Data"

"Engines"
Preset_Speed Reac| "3 Data”.Preset Sp
. —EN hed —eed_Reached

ENO =

Jesli potrzebne bytoby sterowanie kolejnych silnikow, postepowanie bytoby
identyczne, tez w tym celu mogliby$my uzy¢ bloku FB10.

Nalezatoby zadeklarowaé w tabeli deklaracji bloku FB10 dalsze silniki i wywotaé w
nim kolejne bloki FB1. W tabeli symboli nalezatoby doda¢ adresacje i oznaczenia
dla nowych silnikow.

Dalsze informacje znajduja sie w Help >
Contents w rozdziale "Calling References
Helps," "The STL, FBD, or LAD

Language Description," i "Program Control
Instructions."
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11 Konfiguracja systemu rozproszonego

11.1 Tworzenie systemu zdecentralizowanego przy uzyciu sieci
PROFIBUS DP
Standardowo w centralnych systemach sterowania wszelkie sygnaty z
czujnikéw oraz do elementéw wykonawczych przekazywane sg z modutow
sterownika centralnego. Przy wiekszych odlegtosciach pocigga to za sobg
wysokie koszty okablowania.

Stosujgc system rozproszony, umieszczajac moduty wejsé i wyjs¢ w poblizu
czujnikéw i elementéw wykonawczych, ogranicza sie naktad pracy i koszty
okablowania. Potgczenie pomiedzy modutami i jednostkg centralng nastepuje
poprzez sie¢ PROFIBUS-DP.

Dotychczas poznaliSmy programowanie sterownika w systemie centralnym.
Programowanie tego typu systemow i systemu zdecentralizowanego jest
identyczne. Podobnie réwniez odbywa si¢ konfiguracja.

Pomocna bytaby w dalszej pracy znajomos$¢ metod konfiguracji uktadéw
centralnych (patrz rozdz. 2.1 i 6).

ET 200 M-IM153

ET 200B-16DI / 16DO

PROFIBUS-DP network o
master i slave H g"lliﬂ. i

o

MPI
PG/PC do CPU

Master:
np: CPU 315-2DP
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Zatozenie nowego projektu

B PLE dew (o ke Hob

Disler|=] % @) v

LFL e [crums2oe
Lot |2 -Il ﬂ
=
) 57 Faz
= [l 5IMATIC 300 Stason (WY Cycla [ oncubion
- J] rUnS20P
= 28] 57 Frogran{l)
23 Bhcks
CHaek Heas | ume | o

Wprowadzenie sieci PROFIBUS

= S TEPIS TPROIAGS_DF

Zamknij wszelkie dotychczas otwarte
okna i otwoérz tylko SIMATIC
Manager.

Zatéz nowy projekt.

Zatéz w odpowiednim oknie
jednostke centralng typu 315-2DP
(CPU z siecig PROFIBUS-DP).

Postepujgc zgodnie z opisanymi
krokami w rozdz. 2.1 nadaj nowg
nazwe projektowi.

Zaznacz folder z nazwa projektu i
wprowadz sie¢ PROFIBUS uzywajac
menu kontekstu wywotanego prawym
klawiszem myszy.



Konfiguracja stacji

— = () IR

CPU315-2 DP

=-[ SIMATIC 300
= PS-300

[Hlwes
= (g SIMATIC 300
= {1 5M-300
i aee

=3 DI-300

Qi sMa21 ois20c240 )

=+ DO-300

€l sM3220032:0C24v/056 )
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Zaznacz folder SIMATIC 300-Station
i kliknij dwukrotnie Hardware.
Otwiera sie edytor konfiguraciji.

CPU 315-2 DP jest widoczne w raku.
Jesli trzeba, uaktywnij katalog
elementdéw sterownika klikajgc ikonke
na listwie narzedziowej, lub
wybierajac w menu View > Hardware
Catalog.

Wprowadz na pozycje 1 zasilacz
PS307 2A.

Na pozycje 4 wprowadZz modut wejsé
DI32xDC24V, na pozycje 5 modut
wyj$¢ DO32xDC24V/0,5A.



Konfiguracja DP-Master

Insert

Zaznacz na poz. 2.1 DP-Master i
wprowadz DP-master system.

PE307 54

CPUTISZDF | |PROARUSH] DP Mase: Systen 1]

Wszystkie obiekty skonfigurowane jako

P Moy

 plmocaa
D000/ 5

= %% PROFIBUSDP
-l .-

i B-16D)

& B1600

Properties . PAOFIBUS Node 0-1601

uczestnicy sieci DP mozna dowolnie
przemieszczaé¢ w ramach tej sieci.

Znajdz w katalogu modut B-16DlI i
wprowadz go do sieci (puszczajac na
przerywana linig).

W oknie ,Properties” mozna
zadeklarowaé¢ nowg sie¢ oraz adres
wprowadzanego modutu.

Zatwierdz wprowadzony adres 1.

= %% PROFIBUS-DP
T [
= ET 2008
B-16DI

Wykonaj te same operacje dla
modutu B-16DO.

Tym razem adres zostanie
zaproponowany automatycznie.
Zatwierdz ustawienia przyciskiem
OK.
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= 58 PROFIBUS-DP
[ T

g

Lol
DORCC YN 5

| @ 1M153

e

Slot

| o | oo 1 ||

=45 PROFIBUS-DP
D mE -
£ ET 200M

@ M153

=13 Dl-300

[ 5M321 DI32«DC24
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Wprowadz do sieci modut interfejsu
IM153 (modut ET200M) i zatwierdz
zaproponowany adres klawiszem OK.

W naszym przyktadzie przyjete zostang
adresy zaproponowane przez system.
Mozna je jednak w razie potrzeby
zmienic.

Kliknij na sieci ET200M. W dolnej
czesci okna ukaze sie tabela
konfiguracyjna modutu ET200M.
Wybierz pozycije 4.

Do ET200M mozna dotozy¢ dalsze
moduty. WeZzmy np. modut
DI32xDC24V i wprowadzmy na

pozycje 4.

Nalezy zwracaé uwage z jakiego
foldera doktadane sa moduty. Np. dla
systemu ET200M nalezy korzysta¢ z
folderu ET200M.



Zmiana adresow uczestnikow sieci

—

Pz
{8}

—~@ @

R e N

[ - i §
> ~

— |

St | i |

< Save and Compile >

W naszym przyktadzie zmiana adresu
nie jest konieczna. W praktyce jednak
moze byé czasem przydatna.

Zaznaczajac po kolei wszystkich
uczestnikéw sieci sprawdz ich
adresy. System zapewnit ich
niepowtarzalnosc.

Zatézmy, ze chcemy zmienié adresy
w ET200M:

Zaznacz modut na pozycji 4
DO32xDC24V/0,5A.

Zmien w oknie ,Properties”
ustawienie adresuz6na 12, i
zatwierdz ustawienia klawiszem OK.

Na zakoriczenie zapisz i skompilu;
konfiguracje (save and compile).

Zamknij okno.

Przeprowadzenie funkcji ,save and compile” powoduje
jednoczesnie sprawdzenie rozktadu modutéw. W przypadku
bezbtednej konfiguracji stworzone zostang dane systemowe i
bedzie mozna przesta¢ konfiguracje do sterownika.

W przypadku wykorzystania jedynie funkcji zabezpieczenia
(save), moze zostaé zapamietana takze btedna konfiguracja.
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Opcjonalnie: Projektowanie sieci

Konfiguracje systemu rozproszonego
mozna takze przeprowadzic¢
wykonujac projekt sieci.

Kliknij dwukrotnie na sie¢ PROFIBUS
w SIMATIC Manager.

Otwiera sie okno NETPRO.

Mozemy teraz dodawac z katalogu
| dalszych uczestnikow sieci (DP-
4 Slave).

Kliknij dwukrotnie na dowolny
element. Otwarte zostaje okno
konfiguracji sprzetowe;.

Za pomocg funkcji Station > Consistency Check (w oknie "Configuring
Hardware") lub Network > Consistency Check (w oknie "Configuring Networks")
mozna sprawdzi¢ poprawnos¢ wykonania konfiguracji sieciowej przed jej
zabezpieczeniem. W przypadku wykrycia btedéw zostang podane ich miejsca
oraz poprawne rozwigzania.

Dalsze informacje znajduja sie w Help > Contents
w rozdziale "Configuring the Hardware" i
"Configuring the Distributed 1/0."
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Gratulacje!

Znasz juz sposoéb tworzenia projektu w systemie STEP7. Znasz sposéb zaktadania i
konfigurowania stacji, oraz rodzaje i sposoby tworzenia blokéw programowych, a
takze inne funkcje programu np. posta¢ symboliczna czy tez monitorowanie dziatania
programu.

W przypadku watpliwosci, jakie mogg powstaé przy tworzeniu kolejnych projektow
polecamy korzystanie z bogatego systemu pomocy.

Jesli chcesz pogtebi¢ swojg wiedze na temat STEP7 zalecamy wziecie udziatu w
prowadzonych szkoleniach, a takze rozszerzanie wiedzy o szczegéty zawarte w
dokumentaciji do systemu SIMATIC S7.

Zyczymy powodzenia w tworzeniu dalszych projektow.
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Notatki
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Notatki
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SIMATIC - przedstawiciele branzy Automation & Drives w Polsce:

Siemens Sp. z 0.0. Biuro Regionalne Biuro Regionalne Biuro Regionalne Biuro Regionalne Biuro Regionalne
Automation & Drives w Gdansku w Katowicach w Krakowie w Poznaniu we Wroctawiu

ul. Zupnicza 11 ul. Grunwaldzka 413 ul. Gawronow 22 ul. Kraszewskiego 36 ul. Zigbicka 35 ul. Ostrowskiego 30
03-821 Warszawa 80-309 Gdansk 40-527 Katowice 30-110 Krakow 60-164 Poznan 53-238 Wroctaw

tel.: 022-870 98 62 tel.: 058-764 60 92 tel.: 032-208 41 34 tel.: 012-422 77 89 tel.: 061-664 98 61 tel.: 071-777 50 60
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