This user guide describes how to use the National Instruments USB-6008 and National Instruments USB-6009 data acquisition (DAQ) devices and lists specifications.

The NI USB-6008/6009 provides connection to eight single-ended analog input (AI) channels, two analog output (AO) channels, 12 digital input/output (DIO) channels, and a 32-bit counter with a full-speed USB interface. Table 1 compares the devices.

<table>
<thead>
<tr>
<th>Feature</th>
<th>NI USB-6008</th>
<th>NI USB-6009</th>
</tr>
</thead>
<tbody>
<tr>
<td>AI resolution</td>
<td>12 bits differential,</td>
<td>14 bits differential,</td>
</tr>
<tr>
<td></td>
<td>11 bits single-ended</td>
<td>13 bits single-ended</td>
</tr>
<tr>
<td>Maximum AI sample rate,</td>
<td>10 kS/s</td>
<td>48 kS/s</td>
</tr>
<tr>
<td>single channel*</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Maximum AI sample rate,</td>
<td>10 kS/s</td>
<td>48 kS/s</td>
</tr>
<tr>
<td>multiple channels (aggregate)*</td>
<td></td>
<td></td>
</tr>
<tr>
<td>DIO configuration</td>
<td>Open collector†</td>
<td>Each channel individually</td>
</tr>
<tr>
<td></td>
<td></td>
<td>programmable as open collector</td>
</tr>
<tr>
<td></td>
<td></td>
<td>or active drive†</td>
</tr>
</tbody>
</table>

* System-dependent.
† This document uses NI-DAQmx naming conventions. Open-drain is called open collector and push-pull is called active drive.
Figure 1 shows key functional components of the NI USB-6008/6009.

---

**Contents**

- Safety Guidelines ................................................................. 3
- Electromagnetic Compatibility Guidelines .................................... 3
- Unpacking ........................................................................... 4
- Setting Up the NI USB-6008/6009 .................................................. 4
- Using the NI USB-6008/6009 in an Application ............................... 6
- Features ............................................................................... 7
  - USB Connector and USB Cable Strain Relief ......................... 7
  - LED Indicator .................................................................... 8
  - Screw Terminal Connector Plugs ........................................... 8
  - Firmware ........................................................................... 8
- Cables and Accessories ............................................................ 9
- Pinout and Signal Descriptions .................................................. 9
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analog Input</td>
<td>11</td>
</tr>
<tr>
<td>Analog Input Modes and Signal Sources</td>
<td>11</td>
</tr>
<tr>
<td>Floating Signal Sources</td>
<td>12</td>
</tr>
<tr>
<td>Ground-Referenced Signal Sources</td>
<td>13</td>
</tr>
<tr>
<td>Taking Differential Measurements</td>
<td>14</td>
</tr>
<tr>
<td>Taking Referenced Single-Ended Measurements</td>
<td>15</td>
</tr>
<tr>
<td>Digital Trigger</td>
<td>15</td>
</tr>
<tr>
<td>Analog Output</td>
<td>16</td>
</tr>
<tr>
<td>Connecting Analog Output Loads</td>
<td>16</td>
</tr>
<tr>
<td>Minimizing Glitches on the Output Signal</td>
<td>16</td>
</tr>
<tr>
<td>Digital I/O</td>
<td>17</td>
</tr>
<tr>
<td>Source/Sink Information</td>
<td>18</td>
</tr>
<tr>
<td>I/O Protection</td>
<td>19</td>
</tr>
<tr>
<td>Power-On States</td>
<td>19</td>
</tr>
<tr>
<td>Static DIO</td>
<td>19</td>
</tr>
<tr>
<td>PFI 0</td>
<td>19</td>
</tr>
<tr>
<td>Using PFI 0 as a Digital Trigger</td>
<td>19</td>
</tr>
<tr>
<td>Using PFI 0 as an Event Counter</td>
<td>19</td>
</tr>
<tr>
<td>External Reference and Power Source</td>
<td>20</td>
</tr>
<tr>
<td>+2.5 V External Reference</td>
<td>20</td>
</tr>
<tr>
<td>+5 V Power Source</td>
<td>20</td>
</tr>
<tr>
<td>Specifications</td>
<td>20</td>
</tr>
<tr>
<td>Where to Go from Here</td>
<td>27</td>
</tr>
<tr>
<td>Example Programs</td>
<td>27</td>
</tr>
<tr>
<td>Related Documentation</td>
<td>27</td>
</tr>
<tr>
<td>Where to Go for Support</td>
<td>30</td>
</tr>
</tbody>
</table>

**Safety Guidelines**

Operate the NI USB-6008/6009 device only as described in this user guide.

**Caution** Do not operate the NI USB-6008/6009 in a manner not specified in this document. Misuse of the device can result in a hazard. You can compromise the safety protection built into the device if the device is damaged in any way. If the device is damaged, contact National Instruments for repair.

**Caution** Do not substitute parts or modify the device except as described in this document. Use the device only with the chassis, modules, accessories, and cables specified in the installation instructions. You must have all covers and filler panels installed during operation of the device.

**Caution** Do not operate the device in an explosive atmosphere or where there may be flammable gases or fumes. If you must operate the device in such an environment, it must be in a suitably rated enclosure.

**Electromagnetic Compatibility Guidelines**

This product was tested and complies with the regulatory requirements and limits for electromagnetic compatibility (EMC) as stated in the product specifications. These requirements and limits are designed to provide reasonable protection against harmful interference when the product is operated in its intended operational electromagnetic environment.

This product is intended for use in industrial locations. There is no guarantee that harmful interference will not occur in a particular installation, when the product is connected to a test object, or if the product is used in residential areas. To minimize the potential for the product to cause interference to radio and...
television reception or to experience unacceptable performance degradation, install and use this product in strict accordance with the instructions in the product documentation.

Furthermore, any changes or modifications to the product not expressly approved by National Instruments could void your authority to operate it under your local regulatory rules.

Caution To ensure the specified EMC performance, operate this product only with shielded cables and accessories.

Caution This product may become more sensitive to electromagnetic disturbances in the operational environment when test leads are attached or when connected to a test object.

Caution Emissions that exceed the regulatory requirements may occur when this product is connected to a test object.

Caution Changes or modifications not expressly approved by National Instruments could void the user’s authority to operate the hardware under the local regulatory rules.

Unpacking

The NI USB-6008/6009 device ships in an antistatic package to prevent electrostatic discharge (ESD). ESD can damage several components on the device.

Caution Never touch the exposed pins of connectors.

To avoid ESD damage in handling the device, take the following precautions:

- Ground yourself with a grounding strap or by touching a grounded object.
- Touch the antistatic package to a metal part of your computer chassis before removing the device from the package.

Remove the device from the package and inspect it for loose components or any other signs of damage. Notify NI if the device appears damaged in any way. Do not install a damaged device in your computer or chassis.

Store the device in the antistatic package when the device is not in use.

Setting Up the NI USB-6008/6009

Complete the following steps to get started with the NI USB-6008/6009.

Note For information about non-Windows operating system support, refer to the Getting Started with NI-DAQmx Base for Linux and Mac OS X Users document available from ni.com/manuals.

1. Install the application software (if applicable), as described in the installation instructions that accompany your software.

2. Install NI-DAQmx.

Note The NI-DAQmx software is included on the disk shipped with your kit and is available for download at ni.com/support. The documentation for NI-DAQmx is available after installation from Start>All Programs>National Instruments>NI-DAQ. Other NI documentation is available from ni.com/manuals.

1 NI USB-6008/6009 devices are supported by NI-DAQmx 7.5 and later.
3. Install the 16-position screw terminal connector plugs by inserting them into the connector jacks as shown in Figure 2.

![Figure 2. Signal Label Application Diagram](image)

| 1 | Overlay Label with Pin Orientation Guides | 2 | Screw Terminal Connector Plug |
| 3 | Signal Label | 4 | USB Cable |

4. Affix the provided signal labels to the screw terminal connector plugs. You can choose labels with pin numbers, signal names, or blank labels, as shown in Figure 3. Choose one of the labels, align the correct label with the terminals printed on the top panel of your device and apply the label, as shown in Figure 2.

![Figure 3. NI USB-6008/6009 Signal Labels](image)

| 1 | User-Defined Custom Label | 2 | Terminal Number Label | 3 | Digital I/O Label | 4 | Analog Input Differential Signal Name Label | 5 | Analog Input Single-Ended Signal Name Label |

**Note** After you label the screw terminal connector plugs, you must only insert them into the matching connector jack, as indicated by the overlay label on the device.

5. Plug one end of the USB cable into the NI USB-6008/6009 and the other end into an available USB port on the computer.
6. Double-click the **Measurement & Automation** icon, shown at left, on the desktop to open Measurement & Automation Explorer (MAX).

7. Expand **My System»Devices and Interfaces** and verify that the NI USB-6008/6009 is listed. If your device does not appear, press <F5> to refresh the view in MAX. If your device is still not recognized, refer to ni.com/support/daqmx for troubleshooting information.

8. Self-test your device in MAX by right-clicking **NI USB-600x** and selecting **Self-Test**. Self-test performs a brief test to determine successful device installation. When the self-test finishes, a message indicates successful verification or if an error occurred. If an error occurs, refer to ni.com/support/daqmx.

⚠️ **Caution** To ensure the specified EMC performance, operate this product only with shielded cables and accessories.

9. Connect the wires (16 to 28 AWG) of a shielded, multiconductor cable to the screw terminals by stripping 6.35 mm (0.25 in.) of insulation, inserting the wires into the screw terminals, and securely tightening the screws with the flathead screwdriver to a torque of 0.22–0.25 N · m (2.0–2.2 lb · in.). Refer to Figure 6 for the NI USB-6008/6009 pinout.

If using a shielded cable, connect the cable shield to a nearby GND terminal.

**Note** For information about sensors, go to ni.com/sensors. For information about IEEE 1451.4 TEDS smart sensors, go to ni.com/teds.

10. Run a Test Panel in MAX by right-clicking **NI USB-600x** and selecting **Test Panels**.

Click **Start** to test the device functions, or **Help** for operating instructions. Click **Close** to exit the test panel.

### Using the NI USB-6008/6009 in an Application

You can use the DAQ Assistant through many NI application software programs to configure virtual and measurement channels. Table 2 lists DAQ Assistant tutorial locations for NI applications.

**Table 2.** DAQ Assistant Tutorial Locations

<table>
<thead>
<tr>
<th>NI Application</th>
<th>Tutorial Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>LabVIEW</td>
<td>Go to Help»LabVIEW Help. Next, go to Getting Started with LabVIEW» Getting Started with DAQ»Taking an NI-DAQmx Measurement in LabVIEW.</td>
</tr>
<tr>
<td>LabWindows™/CVI™</td>
<td>Go to Help»Contents. Next, go to Using LabWindows/CVI»Data Acquisition» Taking an NI-DAQmx Measurement in LabWindows/CVI.</td>
</tr>
<tr>
<td>LabVIEW SignalExpress</td>
<td>Go to Help»Taking an NI-DAQmx Measurement in SignalExpress.</td>
</tr>
</tbody>
</table>

Refer to the *Where to Go from Here* section for information about programming examples for NI-DAQmx and NI-DAQmx Base.
Features

The NI USB-6008/6009 features a USB connector, USB cable strain relief, two screw terminal connector plugs for I/O, and an LED indicator, as shown in Figure 4.

Figure 4. NI USB-6008/6009 Top and Back Views

USB Connector and USB Cable Strain Relief

The NI USB-6008/6009 features a USB connector for full-speed USB interface. You can provide strain relief for the USB cable by threading a zip tie through the USB cable strain relief ring and tightening around a looped USB cable, as shown in Figure 5.

Figure 5. NI USB-6008/6009 Strain Relief
LED Indicator

The NI USB-6008/6009 device has a green LED indicator that indicates device status, as listed in Table 3. When the device is connected to a USB port, the LED blinks steadily to indicate that the device is initialized and is receiving power from the connection.

Table 3. LED State/Device Status

<table>
<thead>
<tr>
<th>LED State</th>
<th>Device Status</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not lit</td>
<td>Device not connected or in suspend</td>
</tr>
<tr>
<td>On, not blinking</td>
<td>Device connected but not initialized, or the computer is in standby mode.</td>
</tr>
<tr>
<td></td>
<td>In order for the device to be recognized, the device must be connected to a</td>
</tr>
<tr>
<td></td>
<td>computer that has NI-DAQmx installed on it.</td>
</tr>
<tr>
<td>Single-blink</td>
<td>Operating normally</td>
</tr>
</tbody>
</table>

Screw Terminal Connector Plugs

The NI USB-6008/6009 ships with one detachable screw terminal connector plug for analog signals and one detachable screw terminal connector plug for digital signals. These screw terminal connectors provide 16 connections that use 16–28 AWG wire. Refer to step 4 of the Setting Up the NI USB-6008/6009 section for information about selecting labels for the screw terminal connector plugs. Refer to the Pinout and Signal Descriptions section for the device pinout and signal descriptions.

You can order additional connectors and labels for your device. Refer to the Cables and Accessories section for ordering information.

Firmware

The firmware on the NI USB-6008/6009 refreshes whenever the device is connected to a computer with NI-DAQmx. NI-DAQmx automatically uploads the compatible firmware version to the device. The firmware version may be upgraded when new versions of NI-DAQmx release.
Cables and Accessories

Table 4 contains information about cables and accessories available for the NI USB-6008/6009. For a complete list of accessories and ordering information, refer to the pricing section of the NI USB-6008 or NI USB-6009 product page at ni.com.

Table 4. NI USB-6008/6009 Cables and Accessories

<table>
<thead>
<tr>
<th>Accessory</th>
<th>Part Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB-6008/6009 Accessory Kit</td>
<td>779371-01</td>
<td>Four additional screw-terminal connectors, connector labels, and a screwdriver</td>
</tr>
<tr>
<td>USB-6000 Series Prototyping Accessory</td>
<td>779511-01</td>
<td>Unshielded breadboarding accessory for custom-defined signal conditioning and prototyping. You can use up to two accessories per device.</td>
</tr>
<tr>
<td>Hi-Speed USB Cable</td>
<td></td>
<td>1 m and 2 m lengths</td>
</tr>
</tbody>
</table>

Caution: For compliance with Electromagnetic Compatibility (EMC) requirements, this product must be operated with shielded cables and accessories. If unshielded cables or accessories are used, the EMC specifications are no longer guaranteed unless all unshielded cables and/or accessories are installed in a shielded enclosure with properly designed and shielded input/output ports.

Pinout and Signal Descriptions

Figure 6 shows the pinout of the NI USB-6008/6009. Analog input signal names are listed as single-ended analog input name, AIx, and then differential analog input name, (AIx+/–). Refer to Table 5 for a detailed description of each signal.

Figure 6. NI USB-6008/6009 Pinout
Table 5. Signal Descriptions

<table>
<thead>
<tr>
<th>Signal Name</th>
<th>Reference</th>
<th>Direction</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GND</td>
<td>—</td>
<td>—</td>
<td>Ground—The reference point for the single-ended analog input measurements, analog output voltages, digital signals, +5 VDC supply, and +2.5 VDC at the I/O connector, and the bias current return point for differential mode measurements.</td>
</tr>
<tr>
<td>AI &lt;0..7&gt;</td>
<td>Varies</td>
<td>Input</td>
<td>Analog Input Channels 0 to 7—For single-ended measurements, each signal is an analog input voltage channel. For differential measurements, AI 0 and AI 4 are the positive and negative inputs of differential analog input channel 0. The following signal pairs also form differential input channels: AI&lt;1, 5&gt;, AI&lt;2, 6&gt;, and AI&lt;3, 7&gt;. Refer to the Analog Input section for more information.</td>
</tr>
<tr>
<td>AO &lt;0, 1&gt;</td>
<td>GND</td>
<td>Output</td>
<td>Analog Output Channels 0 and 1—Supplies the voltage output of AO channel 0 or AO channel 1. Refer to the Analog Output section for more information.</td>
</tr>
<tr>
<td>P0.&lt;0..7&gt;</td>
<td>GND</td>
<td>Input or Output</td>
<td>Port 0 Digital I/O Channels 0 to 7—You can individually configure each signal as an input or output. Refer to the Digital I/O section for more information.</td>
</tr>
<tr>
<td>P1.&lt;0..3&gt;</td>
<td>GND</td>
<td>Input or Output</td>
<td>Port 1 Digital I/O Channels 0 to 3—You can individually configure each signal as an input or output. Refer to the Digital I/O section for more information.</td>
</tr>
<tr>
<td>PFI 0</td>
<td>GND</td>
<td>Input</td>
<td>PFI 0—This pin is configurable as either a digital trigger or an event counter input. Refer to the PFI 0 section for more information.</td>
</tr>
<tr>
<td>+2.5 V</td>
<td>GND</td>
<td>Output</td>
<td>+2.5 V External Reference—Provides a reference for wrap-back testing. Refer to the +2.5 V External Reference section for more information.</td>
</tr>
<tr>
<td>+5 V</td>
<td>GND</td>
<td>Output</td>
<td>+5 V Power Source—Provides +5 V power up to 200 mA. Refer to the +5 V Power Source section for more information.</td>
</tr>
</tbody>
</table>
Analog Input

The NI USB-6008/6009 has eight analog input channels that you can use for four differential analog input measurements or eight single-ended analog input measurements.

Figure 7 shows the analog input circuitry of the NI USB-6008/6009.

The main blocks featured in the NI USB-6008/6009 analog input circuitry are as follows:

- **MUX**—The NI USB-6008/6009 has one analog-to-digital converter (ADC). The multiplexer (MUX) routes one AI channel at a time to the PGA.

- **PGA**—The programmable-gain amplifier provides input gains of 1, 2, 4, 5, 8, 10, 16, or 20 when configured for differential measurements and gain of 1 when configured for single-ended measurements. The PGA gain is automatically calculated based on the voltage range selected in the measurement application.

- **ADC**—The analog-to-digital converter (ADC) digitizes the AI signal by converting the analog voltage into digital code.

- **AI FIFO**—The NI USB-6008/6009 can perform both single and multiple analog-to-digital conversions of a fixed or infinite number of samples. A first-in-first-out (FIFO) buffer holds data during AI acquisitions to ensure that no data is lost.

Analog Input Modes and Signal Sources

You can configure the AI channels on the NI USB-6008/6009 to take differential or referenced single-ended (RSE) measurements. Table 6 summarizes the recommended analog input mode(s) for floating signal sources and ground-referenced signal sources. Refer to Table 5 for more information about I/O connections for single-ended or differential measurements.
Floating Signal Sources

A floating signal source is not connected to the building ground system, but has an isolated ground-reference point. Some examples of floating signal sources are outputs of transformers, thermocouples, battery-powered devices, optical isolators, and isolation amplifiers. An instrument or device that has an isolated output is a floating signal source.

Refer to the NI Developer Zone document, *Field Wiring and Noise Considerations for Analog Signals*, for more information. To access this document, go to [ni.com/info](http://ni.com/info) and enter the Info Code rdfwn3.

### When to Use Differential Connections with Floating Signal Sources

Use DIFF input connections for any channel that meets any of the following conditions:

- Your application requires input ranges other than ±10 V.
- The input signal is low level and requires greater accuracy.
- The leads connecting the signal to the device are greater than 3 m (10 ft).
- The input signal requires a separate ground-reference point or return signal.

---

**Table 6. Analog Input Configurations**

<table>
<thead>
<tr>
<th>Analog Input Mode</th>
<th>Floating Signal Sources (Not Connected to Building Ground)</th>
<th>Ground-Referenced Signal Sources</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Examples:</td>
<td>Example:</td>
</tr>
<tr>
<td></td>
<td>• Ungrounded thermocouples</td>
<td>• Plug-in instruments with non-isolated outputs</td>
</tr>
<tr>
<td></td>
<td>• Signal conditioning with isolated outputs</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Battery devices</td>
<td></td>
</tr>
</tbody>
</table>

**Differential (DIFF)**

<table>
<thead>
<tr>
<th>Signal Source</th>
<th>NI USB-6008/6009</th>
<th>Ground-loop potential (VA – VB) are added to measured signal</th>
</tr>
</thead>
</table>

**Referenced Single-Ended (RSE)**

<table>
<thead>
<tr>
<th>Signal Source</th>
<th>NI USB-6008/6009</th>
<th>NOT RECOMMENDED</th>
</tr>
</thead>
</table>

**Floating Signal Sources**

A floating signal source is not connected to the building ground system, but has an isolated ground-reference point. Some examples of floating signal sources are outputs of transformers, thermocouples, battery-powered devices, optical isolators, and isolation amplifiers. An instrument or device that has an isolated output is a floating signal source.

Refer to the NI Developer Zone document, *Field Wiring and Noise Considerations for Analog Signals*, for more information. To access this document, go to [ni.com/info](http://ni.com/info) and enter the Info Code rdfwn3.

**When to Use Differential Connections with Floating Signal Sources**

Use DIFF input connections for any channel that meets any of the following conditions:

- Your application requires input ranges other than ±10 V.
- The input signal is low level and requires greater accuracy.
- The leads connecting the signal to the device are greater than 3 m (10 ft).
- The input signal requires a separate ground-reference point or return signal.
• The signal leads travel through noisy environments.
• Two analog input channels, AI+ and AI−, are available for the signal.

DIFF signal connections reduce noise pickup and increase common-mode noise rejection. DIFF signal connections also allow input signals to float within the working voltage of the device.

Refer to the Taking Differential Measurements section for more information about differential connections.

**When to Use Referenced Single-Ended (RSE) Connections with Floating Signal Sources**

Only use RSE input connections if the input signal meets all of the following conditions:

• The input signal can share a common reference point, GND, with other signals that use RSE.
• Your application permits the use of the ±10 V input range.
• The leads connecting the signal to the device are less than 3 m (10 ft).

DIFF input connections are recommended for greater signal integrity for any input signal that does not meet the preceding conditions.

In the single-ended modes, more electrostatic and magnetic noise couples into the signal connections than in DIFF configurations. The coupling is the result of differences in the signal path. Magnetic coupling is proportional to the area between the two signal conductors. Electrical coupling is a function of how much the electric field differs between the two conductors.

With this type of connection, the PGA rejects both the common-mode noise in the signal and the ground potential difference between the signal source and the device ground.

Refer to the Taking Referenced Single-Ended Measurements section for more information about RSE connections.

**Ground-Referenced Signal Sources**

A ground-referenced signal source is a signal source connected to the building system ground. It is already connected to a common ground point with respect to the device, assuming that the computer is plugged into the same power system as the source. Non-isolated outputs of instruments and devices that plug into the building power system fall into this category.

The difference in ground potential between two instruments connected to the same building power system is typically between 1 and 100 mV, but the difference can be much higher if power distribution circuits are improperly connected. If a grounded signal source is incorrectly measured, this difference can appear as measurement error. Follow the connection instructions for grounded signal sources to eliminate this ground potential difference from the measured signal.

Refer to the NI Developer Zone document, Field Wiring and Noise Considerations for Analog Signals, for more information. To access this document, go to ni.com/info and enter the Info Code rdfwn3.

**When to Use Differential Connections with Ground-Referenced Signal Sources**

Use DIFF input connections for any channel that meets any of the following conditions:

• Your application requires input ranges other than ±10 V.
• The input signal is low level and requires greater accuracy.
• The leads connecting the signal to the device are greater than 3 m (10 ft).
• The input signal requires a separate ground-reference point or return signal.
• The signal leads travel through noisy environments.
• Two analog input channels, AI+ and AI−, are available for the signal.
DIFF signal connections reduce noise pickup and increase common-mode noise rejection. DIFF signal connections also allow input signals to float within the working voltage of the device.

Refer to the Taking Differential Measurements section for more information about differential connections.

**When to Use Referenced Single-Ended (RSE) Connections with Ground-Referenced Signal Sources**

Do not use RSE connections with ground-referenced signal sources. Use differential connections instead.

As shown in the bottom-rightmost cell of Table 6, there can be a potential difference between GND and the ground of the sensor. In RSE mode, this ground loop causes measurement errors.

**Taking Differential Measurements**

For differential signals, connect the positive lead of the signal to the AI+ terminal, and the negative lead to the AI– terminal.

![Figure 8. Connecting a Differential Voltage Signal](image)

The differential input mode can measure ±20 V signals in the ±20 V range. However, the maximum voltage on any one pin is ±10 V with respect to GND. For example, if AI 1 is +10 V and AI 5 is –10 V, then the measurement returned from the device is +20 V.

![Figure 9. Example of a Differential 20 V Measurement](image)
Connecting a signal greater than ±10 V on either pin results in a clipped output.

**Figure 10.** Exceeding ±10 V on AI Returns Clipped Output

**Taking Referenced Single-Ended Measurements**

To connect referenced single-ended (RSE) voltage signals to the NI USB-6008/6009, connect the positive voltage signal to an AI terminal, and the ground signal to a GND terminal, as shown in Figure 11.

**Figure 11.** Connecting a Referenced Single-Ended Voltage Signal

When no signals are connected to the analog input terminal, the internal resistor divider may cause the terminal to float to approximately 1.4 V when the analog input terminal is configured as RSE. This behavior is normal and does not affect the measurement when a signal is connected.

**Digital Trigger**

You can configure PFI 0 as a digital trigger input for analog input tasks. Refer to the *Using PFI 0 as a Digital Trigger* section for more information.
Analog Output

The NI USB-6008/6009 has two independent analog output channels that can generate outputs from 0 to 5 V. All updates of analog output channels are software-timed. GND is the ground-reference signal for the analog output channels.

Figure 12 shows the circuitry of one analog output channel on the NI USB-6008/6009.

![Circuitry of One Analog Output Channel](image)

The main block featured in the NI USB-6008/6009 analog output circuitry is the digital-to-analog converter (DAC), which converts digital codes to analog voltages. There is one DAC for each analog output line.

Connecting Analog Output Loads

To connect loads to the NI USB-6008/6009, connect the positive lead of the load to the AO terminal, and connect the ground of the load to a GND terminal, as shown in Figure 13.

![Connecting a Load](image)

Minimizing Glitches on the Output Signal

When you use a DAC to generate a waveform, you may observe glitches in the output signal. These glitches are normal; when a DAC switches from one voltage to another, it produces glitches due to released charges. The largest glitches occur when the most significant bit of the DAC code changes. You can build a lowpass deglitching filter to remove some of these glitches, depending on the frequency and nature of the output signal. For more information about minimizing glitches, refer to the KnowledgeBase document, Reducing Glitches on the Analog Output of MIO DAQ Devices. To access this document, go to ni.com/info and enter the Info Code exszeK.
Digital I/O

The NI USB-6008/6009 has 12 digital lines on two ports, Port 0 has eight lines, P0.<0..7>, and Port 1 has four lines, P1.<0..3>. GND is the ground-reference signal for the digital I/O ports. You can individually program all lines as inputs or outputs.

Figure 14 shows P0.<0..7> connected to example signals configured as digital inputs and digital outputs. You can configure P1.<0..3> similarly.

![Diagram](image)

**Figure 14.** Example of Connecting a Load

1. P0.0 configured as an open collector digital output driving an LED
2. P0.2 configured as an active drive digital output driving an LED
3. P0.4 configured as a digital input receiving a TTL signal from a gated inverter
4. P0.7 configured as a digital input receiving a 0 V or 5 V signal from a switch

**Caution** Exceeding the maximum input voltage ratings or maximum output ratings, which are listed in the Specifications section, can damage the device and the computer. National Instruments is not liable for any damage resulting from such signal connections.
Source/Sink Information

The default configuration of the NI USB-6008/6009 digital I/O ports is open collector, allowing 5 V operation, with an onboard 4.7 kΩ pull-up resistor. An external user-provided pull-up resistor can be added to increase the source current drive up to a 8.5 mA limit per line as shown in Figure 15.1

![Figure 15. Example of Connecting an External User-Provided Resistor](image)

The NI USB-6009 ports can also be configured as active drive using the NI-DAQmx API, allowing 3.3 V operation with a source/sink current limit of ±8.5 mA. For more information about how to set the DIO configuration, refer to the KnowledgeBase document, *Configuring NI Devices to be Open-Drain (Open Collector) or Push-Pull (Active Drive)*. To access this document, go to [ni.com/info](http://ni.com/info) and enter the Info Code ex52sp.

Complete the following steps to determine the value of the user-provided pull-up resistor:

1. Place an ammeter in series with the load.
2. Place a variable resistor between the digital output line and the +5 V supply.
3. Set P0.0 to high.
4. Adjust the variable resistor until the ammeter current reads as the intended current. The intended current must be less than 8.5 mA.
5. Remove the ammeter and variable resistor from your circuit.
6. Measure the resistance of the variable resistor. The measured resistance is the ideal value of the pull-up resistor.
7. Select a static resistor value for your pull-up resistor that is greater than or equal to the ideal resistance.
8. Reconnect the load circuit and the pull-up resistor.

---

1 This document uses NI-DAQmx naming conventions. Open-drain is called open collector and push-pull is called active drive.
**I/O Protection**

To protect the NI USB-6008/6009 against overvoltage, undervoltage, and overcurrent conditions, as well as ESD events, you should avoid these fault conditions by using the following guidelines:

- If you configure a DIO line as an output, do not connect it to any external signal source, ground signal, or power supply.
- If you configure a DIO line as an output, understand the current requirements of the load connected to these signals. Do not exceed the specified current output limits of the DAQ device.
  
  National Instruments has several signal conditioning solutions for digital applications requiring high current drive.
- If you configure a DIO line as an input, do not drive the line with voltages outside of its normal operating range. The DIO lines have a smaller operating range than the AI signals.
- Treat the DAQ device as you would treat any static-sensitive device. Always properly ground yourself and the equipment when handling the DAQ device or connecting to it.

**Power-On States**

At system startup and reset, the hardware sets all DIO lines to high-impedance inputs. The DAQ device does not drive the signal high or low. Each line has a weak pull-up resistor connected to it.

**Static DIO**

Each of the NI USB-6008/6009 DIO lines can be used as a static DI or DO line. You can use static DIO lines to monitor or control digital signals. All samples of static DI lines and updates of DO lines are software-timed.

**PFI 0**

PFI 0 is configurable as either a digital trigger input or an event counter input.

**Using PFI 0 as a Digital Trigger**

When an analog input task is defined, you can configure PFI 0 as a digital trigger input. When the digital trigger is enabled, the AI task waits for a rising or falling edge on PFI 0 before starting the acquisition. To use AI Start Trigger (ai/StartTrigger) with a digital source, specify PFI 0 as the source and select a rising or falling edge.

**Using PFI 0 as an Event Counter**

You can configure PFI 0 as a source for counting digital edges. In this mode, falling-edge events are counted using a 32-bit counter. For more information about event timing requirements, refer to the *Specifications* section.
External Reference and Power Source

The NI USB-6008/6009 creates an external reference and supplies a power source. All voltages are relative to ground (GND).

+2.5 V External Reference

The NI USB-6008/6009 creates a high-purity reference voltage supply for the ADC using a multi-state regulator, amplifier, and filter circuit. You can use the resulting +2.5 V reference voltage as a signal for self-test.

+5 V Power Source

The NI USB-6008/6009 supplies a 5 V, 200 mA output. You can use this source to power external components.

Note When the device is in USB suspend, the output is disabled.

Specifications

The following specifications are typical at 25 °C, unless otherwise noted.

Analog Input

Analog inputs
- Differential ..................................................... 4
- Single-ended .................................................. 8, software-selectable

Input resolution
- NI USB-6008
  - Differential ............................................. 12 bits
  - Single-ended .......................................... 11 bits
- NI USB-6009
  - Differential ............................................. 14 bits
  - Single-ended .......................................... 13 bits

Max sample rate (aggregate)\(^1\)
- NI USB-6008 ................................................. 10 kS/s
- NI USB-6009 ................................................. 48 kS/s

Converter type .......................................................... Successive approximation

AI FIFO .......................................................... 512 bytes

Timing resolution ................................................... 41.67 ns (24 MHz timebase)

Timing accuracy ..................................................... 100 ppm of actual sample rate

Input range
- Differential ..................................................... ±20 V\(^2\), ±10 V, ±5 V, ±4 V, ±2.5 V, ±2 V, ±1.25 V, ±1 V
- Single-ended .................................................. ±10 V

\(^1\) System-dependent.

\(^2\) ±20 V means that |AI+ – (AI–)| ≤ 20 V. However, AI+ and AI– must both be within ±10 V of GND. Refer to the Taking Differential Measurements section for more information.
Working voltage.....................................................±10 V
Input impedance...................................................144 kΩ
Overvoltage protection.........................................±35 V
Trigger source .....................................................Software or external digital trigger

System noise\(^1\)
  Differential
    ±20 V range ........................................5 mVrms
    ±1 V range ........................................0.5 mVrms
  Single-ended
    ±10 V range ........................................5 mVrms

Absolute accuracy at full scale, differential\(^2\)

<table>
<thead>
<tr>
<th>Range (V)</th>
<th>Typical at 25 °C (mV)</th>
<th>Maximum over Temperature (mV)</th>
</tr>
</thead>
<tbody>
<tr>
<td>±20</td>
<td>14.7</td>
<td>138</td>
</tr>
<tr>
<td>±10</td>
<td>7.73</td>
<td>84.8</td>
</tr>
<tr>
<td>±5</td>
<td>4.28</td>
<td>58.4</td>
</tr>
<tr>
<td>±4</td>
<td>3.59</td>
<td>53.1</td>
</tr>
<tr>
<td>±2.5</td>
<td>2.56</td>
<td>45.1</td>
</tr>
<tr>
<td>±2</td>
<td>2.21</td>
<td>42.5</td>
</tr>
<tr>
<td>±1.25</td>
<td>1.70</td>
<td>38.9</td>
</tr>
<tr>
<td>±1</td>
<td>1.53</td>
<td>37.5</td>
</tr>
</tbody>
</table>

Absolute accuracy at full scale, single-ended

<table>
<thead>
<tr>
<th>Range (V)</th>
<th>Typical at 25 °C (mV)</th>
<th>Maximum over Temperature (mV)</th>
</tr>
</thead>
<tbody>
<tr>
<td>±10</td>
<td>14.7</td>
<td>138</td>
</tr>
</tbody>
</table>

Analog Output
  Analog outputs.............................................2
  Output resolution ........................................12 bits
  Maximum update rate ....................................150 Hz, software-timed
  Output range ........................................0 to +5 V
  Output impedance ......................................50 Ω
  Output current drive ....................................5 mA
  Power-on state .........................................0 V

\(^1\) System noise measured at maximum sample rate.
\(^2\) Input voltages may not exceed the working voltage range.
Slew rate................................................................. 1 V/μs
Short circuit current ............................................. 50 mA
Absolute accuracy (no load)
   Typical.......................................................... 7 mV
   Maximum at full scale ................................. 36.4 mV

**Digital I/O**

Digital I/O lines
- P0.<0..7> ...................................................... 8 lines
- P1.<0..3> ...................................................... 4 lines

Direction control .................................................. Each channel individually programmable as input or output

Output driver type\(^1\)
- NI USB-6008 ................................................. Open collector
- NI USB-6009 ................................................. Each channel individually programmable as open collector or active drive

Compatibility ....................................................... TTL, LVTTL, CMOS

Absolute maximum voltage range ...................... –0.5 to 5.8 V with respect to GND

Pull-up resistor .................................................... 4.7 kΩ to 5 V

Power-on state .................................................. Input

Digital logic levels

<table>
<thead>
<tr>
<th>Level</th>
<th>Min</th>
<th>Max</th>
</tr>
</thead>
<tbody>
<tr>
<td>Input low voltage</td>
<td>–0.3 V</td>
<td>0.8 V</td>
</tr>
<tr>
<td>Input high voltage</td>
<td>2.0 V</td>
<td>5.8 V</td>
</tr>
<tr>
<td>Input leakage current</td>
<td>—</td>
<td>50 μA</td>
</tr>
<tr>
<td>Output low voltage (I = 8.5 mA)</td>
<td>—</td>
<td>0.8 V</td>
</tr>
<tr>
<td>Output high voltage</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Active drive, I = –8.5 mA</td>
<td>2.0 V</td>
<td>3.5 V</td>
</tr>
<tr>
<td>Open collector, I = –0.6 mA, nominal</td>
<td>2.0 V</td>
<td>5.0 V</td>
</tr>
<tr>
<td>Open collector, I = –8.5 mA, with external pull-up resistor</td>
<td>2.0 V</td>
<td>—</td>
</tr>
</tbody>
</table>

**External Voltage**

+5 V output (200 mA maximum)
   Minimum ................................................. +4.85 V
   Typical.................................................. +5 V

+2.5 V output (1 mA maximum) ...................... +2.5 V

+2.5 V accuracy ........................................... 0.25% maximum

Reference temperature drift ...................... 50 ppm/°C maximum

\(^1\) This document uses NI-DAQmx naming conventions. Open-drain is called open collector and push-pull is called active drive.
Event Counter
Number of counters ............................................... 1
Resolution .............................................................. 32 bits
Counter measurements ........................................... Edge counting (falling-edge)
Counter direction ................................................... Count up
Pull-up resistor ....................................................... 4.7 kΩ to 5 V
Maximum input frequency ..................................... 5 MHz
Minimum high pulse width .................................... 100 ns
Minimum low pulse width ...................................... 100 ns
Input high voltage .................................................. 2.0 V
Input low voltage .................................................... 0.8 V

Bus Interface
USB specification .................................................. USB 2.0 full-speed
USB bus speed ....................................................... 12 Mb/s

Power Requirements
USB
  4.10 to 5.25 VDC
    Typical....................................................... 80 mA
    Maximum.................................................... 500 mA
USB suspend
    Typical....................................................... 300 µA
    Maximum.................................................... 500 µA

Physical Characteristics
Dimensions ............................................................ Refer to Figure 16.
Without connectors ................................................. 63.5 mm × 85.1 mm × 23.2 mm
  (2.50 in. × 3.35 in. × 0.91 in.)
With connectors ..................................................... 81.8 mm × 85.1 mm × 23.2 mm
  (3.22 in. × 3.35 in. × 0.91 in.)
Weight
Without connectors ........................................54 g (1.9 oz)
With connectors .............................................84 g (3 oz)
I/O connectors........................................................USB series B receptacle,
(2) 16 position screw terminal plugs
Screw-terminal wiring ...................................16 to 28 AWG
Torque for screw terminals .......................0.22–0.25 N · m (2.0–2.2 lb · in.)

If you need to clean the module, wipe it with a dry towel.

Safety Voltages
Connect only voltages that are within these limits.
Channel-to-GND ..................................................±30 V max, Measurement Category I

Measurement Category I is for measurements performed on circuits not directly connected to the electrical distribution system referred to as MAINS voltage. MAINS is a hazardous live electrical supply system that powers equipment. This category is for measurements of voltages from specially protected secondary circuits. Such voltage measurements include signal levels, special equipment, limited-energy parts of equipment, circuits powered by regulated low-voltage sources, and electronics.

⚠️ Caution Do not use this module for connection to signals or for measurements within Measurement Categories II, III, or IV.
Environmental

Temperature (IEC 60068-2-1 and IEC 60068-2-2)
- Operating: 0 to 55 °C
- Storage: -40 to 85 °C

Humidity (IEC 60068-2-56)
- Operating: 5 to 95% RH, noncondensing
- Storage: 5 to 90% RH, noncondensing

Pollution Degree (IEC 60664): 2

Maximum altitude: 2,000 m

Indoor use only.

Safety

This product meets the requirements of the following standards of safety for electrical equipment for measurement, control, and laboratory use:
- IEC 61010-1, EN 61010-1
- UL 61010-1, CSA 61010-1

Note: For UL and other safety certifications, refer to the product label or the Online Product Certification section.

Electromagnetic Compatibility

This product meets the requirements of the following EMC standards for electrical equipment for measurement, control, and laboratory use:
- EN 61326-1 (IEC 61326-1): Class A emissions; Basic immunity
- EN 55011 (CISPR 11): Group 1, Class A emissions
- AS/NZS CISPR 11: Group 1, Class A emissions
- FCC 47 CFR Part 15B: Class A emissions
- ICES-001: Class A emissions

Note: In the United States (per FCC 47 CFR), Class A equipment is intended for use in commercial, light-industrial, and heavy-industrial locations. In Europe, Canada, Australia and New Zealand (per CISPR 11) Class A equipment is intended for use only in heavy-industrial locations.

Note: Group 1 equipment (per CISPR 11) is any industrial, scientific, or medical equipment that does not intentionally generates radio frequency energy for the treatment of material or inspection/analysis purposes.

Note: For EMC declarations and certifications, and additional information, refer to the Environmental Management section.

CE Compliance

This product meets the essential requirements of applicable European Directives as follows:
- 2006/95/EC; Low-Voltage Directive (safety)
- 2004/108/EC; Electromagnetic Compatibility Directive (EMC)
Online Product Certification

To obtain product certifications and the Declaration of Conformity (DoC) for this product, visit ni.com/certification, search by model number or product line, and click the appropriate link in the Certification column.

Environmental Management

NI is committed to designing and manufacturing products in an environmentally responsible manner. NI recognizes that eliminating certain hazardous substances from our products is beneficial to the environment and to NI customers.

For additional environmental information, refer to the NI and the Environment Web page at ni.com/environment. This page contains the environmental regulations and directives with which NI complies, as well as other environmental information not included in this document.

Waste Electrical and Electronic Equipment (WEEE)

EU Customers  The symbol indicates that the waste products should be disposed of separately from municipal household waste according to Directive 2002/96/EC of the European Parliament and the Council on waste electrical and electronic equipment (WEEE). At the end of the product life cycle, all products must be sent to a WEEE collection and recycling center. Proper disposal of WEEE reduces the environmental impact and risk to human health due to potentially hazardous substances that are generally used in such equipment. Your cooperation in the correct disposal of the products will contribute to the effective usage of natural resources. For information about the available collection and recycling scheme in a particular country, refer to ni.com/citizenship/weee.

电子信息产品污染控制管理办法（中国 RoHS）

中国客户  National Instruments 符合中国电子信息产品中限制使用某些有害物质指令 (RoHS)。关于 National Instruments 中国 RoHS 合规性信息，请登录 ni.com/environment/rohs_china。(For information about China RoHS compliance, go to ni.com/environment/rohs_china.)
Where to Go from Here

This section lists where you can find example programs for the NI USB-6008/6009 and relevant documentation.

Example Programs

NI-DAQmx and NI-DAQmx software include example programs to help you get started programming with the NI USB-6008/6009. Modify example code and save it in an application, or use examples to develop a new application, or add example code to an existing application.

NI-DAQmx

To locate NI software examples, go to ni.com/info and enter the Info Code daqmxexp. For additional examples, refer to zone.ni.com.

To run examples without the device installed, use an NI-DAQmx simulated device. For more information, in Measurement & Automation Explorer (MAX), select Help»Help Topics»NI-DAQmx»MAX Help for NI-DAQmx and search for simulated devices.

NI-DAQmx Base

NI-DAQmx Base examples are accessible from Start»All Programs»National Instruments»NI-DAQmx Base»Examples.

Related Documentation

Each application software package and driver includes information about writing applications for taking measurements and controlling measurement devices. The following references to documents assume you have NI-DAQmx 9.3 or later, and where applicable, version 8.5 or later of the NI application software.

NI-DAQmx

The NI USB-6008/6009 Quick Start packaged with the NI USB-6008/6009 describes how to install NI-DAQmx software, install the device, and confirm that your device is operating properly.

The NI-DAQ Readme lists which devices, ADEs, and NI application software are supported by this version of NI-DAQ. Select Start»All Programs»National Instruments»NI-DAQ»NI-DAQ Readme.

The NI-DAQmx Help contains API overviews, general information about measurement concepts, key NI-DAQmx concepts, and common applications that are applicable to all programming environments. Select Start»All Programs»National Instruments»NI-DAQ»NI-DAQmx Help.

NI-DAQmx Base (Linux/Mac OS X/LabVIEW PDA 8.x)

The NI-DAQmx Base Getting Started Guide describes how to install your NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device, and how to confirm that your device is operating properly. In Windows, select Start»All Programs»National Instruments»NI-DAQmx Base»Documentation»NI-DAQmx Base Getting Started Guide.

The Getting Started with NI-DAQmx Base for Linux and Mac OS X Users document describes how to install your NI-DAQmx Base software, your NI-DAQmx Base-supported DAQ device, and how to confirm that your device is operating properly on your Linux or Mac machine.

The NI-DAQmx Base Readme lists which devices are supported by a version of NI-DAQmx Base. In Windows, select Start»All Programs»National Instruments»NI-DAQmx Base»DAQmx Base Readme.
The **NI-DAQmx Base VI Reference Help** contains VI reference and general information about measurement concepts. In LabVIEW, select **Help»NI-DAQmx Base VI Reference Help**.

The **NI-DAQmx Base C Function Reference Help** contains C reference and general information about measurement concepts. In Windows, select **Start»All Programs»National Instruments»NI-DAQmx Base»Documentation»C Function Reference Help**.

**Note** All NI-DAQmx Base documentation for Linux is installed at `/usr/local/natinis/nidaqmxbase/documentation`.

**Note** All NI-DAQmx Base documentation for Mac OS X is installed at `/Applications/National Instruments/NI-DAQmx Base/documentation`.

**LabVIEW**

If you are a new user, use the *Getting Started with LabVIEW* manual to familiarize yourself with the LabVIEW graphical programming environment and the basic LabVIEW features you use to build data acquisition and instrument control applications. Open the *Getting Started with LabVIEW* manual by selecting **Start»All Programs»National Instruments»LabVIEW»LabVIEW Manuals** or by navigating to the `labview\manuals` directory and opening `LV_Getting_Started.pdf`.

Use the **LabVIEW Help**, available by selecting **Help»LabVIEW Help** in LabVIEW, to access information about LabVIEW programming concepts, step-by-step instructions for using LabVIEW, and reference information about LabVIEW VIs, functions, palettes, menus, and tools. Refer to the following locations on the **Contents** tab of the **LabVIEW Help** for information about NI-DAQmx:

- **Getting Started with LabVIEW**—Includes overview information and a tutorial on how to take an NI-DAQmx measurement in LabVIEW using the DAQ Assistant.
- **VI and Function Reference**—Describes the LabVIEW NI-DAQmx VIs and functions.
- **Property and Method Reference** contains the property reference.
- **Taking Measurements**—Contains the conceptual and how-to information you need to acquire and analyze measurement data in LabVIEW, including common measurements, measurement fundamentals, NI-DAQmx key concepts, and device considerations.

**LabWindows/CVI**

The **Data Acquisition** book of the **LabWindows/CVI Help** contains *Taking an NI-DAQmx Measurement in LabWindows/CVI*, which includes step-by-step instructions about creating a measurement task using the DAQ Assistant. In LabWindows™/CVI™, select **Help»Contents**, then select **Using LabWindows/CVI»Data Acquisition**. This book also contains information about accessing detailed information through the **NI-DAQmx Help**.

The **NI-DAQmx Library** book of the **LabWindows/CVI Help** contains API overviews and function reference for NI-DAQmx. Select **Library Reference»NI-DAQmx Library** in the **LabWindows/CVI Help**.
**Measurement Studio**

If you program your NI-DAQmx-supported device in Measurement Studio using Visual C# or Visual Basic .NET, you can interactively create channels and tasks by launching the DAQ Assistant from MAX or from within Visual Studio. You can use Measurement Studio to generate the configuration code based on your task or channel. Refer to the *DAQ Assistant Help* for additional information about generating code.

The *NI Measurement Studio Help* is fully integrated with the Microsoft Visual Studio help. To view this help file in Visual Studio, select *Measurement Studio»NI Measurement Studio Help*. For information related to developing with NI-DAQmx, refer to the following topics within the NI Measurement Studio Help:

- For step-by-step instructions on how to create an NI-DAQmx application using the Measurement Studio Application Wizard and the DAQ Assistant, refer to *Walkthrough: Creating a Measurement Studio NI-DAQmx Application*.
- For help with NI-DAQmx methods and properties, refer to `NationalInstruments.DAQmx Namespace` and `NationalInstruments.DAQmx.ComponentModel Namespace`.
- For conceptual help with NI-DAQmx, refer to *Using the Measurement Studio NI-DAQmx .NET Library and Developing with Measurement Studio NI-DAQmx*.
- For general help with programming in Measurement Studio, refer to *Getting Started with the Measurement Studio Class Libraries*.

To create an application in Visual Basic .NET or Visual C#, follow these general steps:

1. In Visual Studio, select *File»New»Project* to launch the New Project dialog box.
2. In the Project types pane, expand the *Visual Basic* or *Visual C#* node, depending on which language you want to create the project in, and select *Measurement Studio*.
3. Choose a project type. You add DAQ tasks as a part of this step.

**ANSI C without NI Application Software**

The *NI-DAQmx Help* contains API overviews and general information about measurement concepts. Select *Start»All Programs»National Instruments»NI-DAQ»NI-DAQmx Help*.

The *NI-DAQmx C Reference Help* describes the NI-DAQmx Library functions, which you can use with National Instruments data acquisition devices to develop instrumentation, acquisition, and control applications. Select *Start»All Programs»National Instruments»NI-DAQ»Text-Based Code Support»NI-DAQmx C Reference Help*.

**.NET Languages without NI Application Software**

With the Microsoft .NET Framework version 2.0 or later, you can use NI-DAQmx to create applications using Visual C# and Visual Basic .NET without Measurement Studio. You need Microsoft Visual Studio .NET 2005 or later for the API documentation to be installed.

The installed documentation contains the NI-DAQmx API overview, measurement tasks and concepts, and function reference. This help is fully integrated into the Visual Studio documentation. To view the NI-DAQmx .NET documentation, go to *Start»All Programs»National Instruments»NI-DAQ»Text-Based Code Support*. For function reference, refer to the `NationalInstruments.DAQmx Namespace` and `NationalInstruments.DAQmx.ComponentModel Namespace` topics. For conceptual help, refer to the *Using the Measurement Studio NI-DAQmx .NET Library and Developing with Measurement Studio NI-DAQmx sections*.

To get to the same help topics from within Visual Studio 2005 or 2008, go to *Help»Contents* and select *Measurement Studio* from the *Filtered By* drop-down list. To get to the same help topics from within Visual Studio 2008, select *Help»Contents* and select *Measurement Studio* from the *Filtered By* drop-down list.
Visual Studio 2010, go to Help » View Help and select NI Measurement Studio Help from the Related Links section.

Training Courses
If you need more help getting started developing an application with NI products, NI offers training courses. To enroll in a course or obtain a detailed course outline, refer to ni.com/training.

Technical Support on the Web
For additional support, refer to ni.com/support or zone.ni.com.

Note You can download these documents at ni.com/manuals.

DAQ specifications and some DAQ manuals are available as PDFs. You must have Adobe Acrobat Reader with Search and Accessibility 5.0.5 or later installed to view the PDFs. Refer to the Adobe Systems Incorporated Web site at www.adobe.com to download Acrobat Reader. Refer to the National Instruments Product Manuals Library at ni.com/manuals for updated documentation resources.

Where to Go for Support
The National Instruments Web site is your complete resource for technical support. At ni.com/support you have access to everything from troubleshooting and application development self-help resources to email and phone assistance from NI Application Engineers.

A Declaration of Conformity (DoC) is our claim of compliance with the Council of the European Communities using the manufacturer’s declaration of conformity. This system affords the user protection for electromagnetic compatibility (EMC) and product safety. You can obtain the DoC for your product by visiting ni.com/certification. If your product supports calibration, you can obtain the calibration certificate for your product at ni.com/calibration.

National Instruments corporate headquarters is located at 11500 North Mopac Expressway, Austin, Texas, 78759-3504. National Instruments also has offices located around the world to help address your support needs. For telephone support in the United States, create your service request at ni.com/support and follow the calling instructions or dial 512 795 8248. For telephone support outside the United States, visit the Worldwide Offices section of ni.com/niglobal to access the branch office Web sites, which provide up-to-date contact information, support phone numbers, email addresses, and current events.